aboutsummaryrefslogtreecommitdiff
path: root/devel/cook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cook/Makefile')
-rw-r--r--devel/cook/Makefile27
1 files changed, 5 insertions, 22 deletions
diff --git a/devel/cook/Makefile b/devel/cook/Makefile
index 830c95144d14..11c7f0503a29 100644
--- a/devel/cook/Makefile
+++ b/devel/cook/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= cook
-PORTVERSION= 2.23
-PORTREVISION= 1
+PORTVERSION= 2.24
CATEGORIES= devel
MASTER_SITES= http://gd.tuwien.ac.at/softeng/Aegis/cook/
-MAINTAINER= ports@freebsd.org
+MAINTAINER= jasone@canonware.com
COMMENT= Like make(1), but more powerful and clean
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
@@ -19,11 +18,10 @@ LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib \
YACC=yacc
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= c_incl.1 cook.1 cook_bom.1 cook_lic.1 cook_rsh.1 cookfp.1 cooktime.1 \
find_libs.1 make2cook.1 roffpp.1
-MANPREFIX = ${PREFIX}/share/cook
-MANLANG = "" en
MANCOMPRESSED= no
# Make sure that the whole directory tree exists.
@@ -32,23 +30,8 @@ pre-install:
${MKDIR} ${PREFIX}/lib/cook/en/LC_MESSAGES
# cook installs extra copies of the manpages in a directory that MANLANG can't
-# cope with, so shuffle things around a bit.
+# cope with. Delete the extra copies.
post-install:
- @${MKDIR} ${PREFIX}/share/cook/en/man1
- @${MKDIR} ${PREFIX}/share/cook/man/en/man1
-.for manpage in ${MAN1}
- @${MV} ${PREFIX}/share/cook/en/man1/${manpage} \
- ${PREFIX}/share/cook/man/en/man1/
-.endfor
- @${TOUCH} ${PREFIX}/share/cook/en/man1/.not_empty
- @${MKDIR} ${PREFIX}/share/cook/man/man1
-.for manpage in ${MAN1}
- @${MV} ${PREFIX}/man/man1/${manpage} ${PREFIX}/share/cook/man/man1/
-.endfor
- @echo
- @echo "Add ${PREFIX}/share/cook/man to your MANPATH in order to" \
- "access the manual"
- @echo "pages included with this port."
- @echo
+ @${RM} -rf ${PREFIX}/share/cook/en/man1
.include <bsd.port.mk>