aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsweb3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cvsweb3/Makefile')
-rw-r--r--devel/cvsweb3/Makefile66
1 files changed, 0 insertions, 66 deletions
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
deleted file mode 100644
index 9efc8e677c8e..000000000000
--- a/devel/cvsweb3/Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
-# New ports collection makefile for: cvsweb
-# Date created: 27 Jun 1999
-# Whom: SADA Kenji <sada@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= cvsweb
-PORTVERSION= ${REV_ZELLER}.${REV_KNU}
-CATEGORIES= devel www
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= knu
-
-MAINTAINER= knu@FreeBSD.org
-
-NO_BUILD= yes
-
-USE_PERL5= yes
-
-# This version of cvsweb is Zeller's version + knu's enhancements.
-REV_ZELLER= 1.101
-REV_KNU= 1.24
-
-# Specify where your repository belongs.
-# (You can reconfigure it after installation anyway)
-.if defined(PACKAGE_BUILDING) || !defined(CVSROOT) || empty(CVSROOT)
-CVSROOT= /home/cvs
-.endif
-
-# Specify the title of your cvsweb site.
-TITLE?= My CVS Repository
-
-# Specify these directories in relative paths to ${PREFIX}.
-CGIDIR?= share/apache/cgi-bin
-ICONSDIR?= share/apache/icons
-
-PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}"
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-do-configure:
- cd ${WRKSRC} && ${PERL} -i -pe "\
- s;/usr/bin/perl5;${PERL};g; \
- s;/usr/local;${PREFIX};g; \
- s;/home/cvs;${CVSROOT};g; \
- s;'Local Repository';'${TITLE}';g; \
- " cvsweb.cgi cvsweb.conf
-
-do-install:
- ${MKDIR} ${PREFIX}/${CGIDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/cvsweb.cgi ${PREFIX}/${CGIDIR}/
- ${INSTALL_DATA} ${WRKSRC}/cvsweb.conf ${PREFIX}/etc/cvsweb.conf.sample
- ${MKDIR} ${PREFIX}/${ICONSDIR}/cvsweb
- cd ${WRKSRC}/icons && ${INSTALL_DATA} * ${PREFIX}/${ICONSDIR}/cvsweb/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cvsweb
- cd ${WRKSRC} && ${INSTALL_DATA} ChangeLog INSTALL README README.knu TODO ${PREFIX}/share/doc/cvsweb/
-.endif
-
-post-install:
-.if defined(PACKAGE_BUILDING)
- ${ECHO} "@unexec rmdir -p %D/${CGIDIR} %D/${ICONSDIR} 2>/dev/null || true" >> ${TMPPLIST}
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>