aboutsummaryrefslogtreecommitdiff
path: root/devel/cweb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cweb/Makefile')
-rw-r--r--devel/cweb/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/cweb/Makefile b/devel/cweb/Makefile
index 35741b82effe..395241c0da13 100644
--- a/devel/cweb/Makefile
+++ b/devel/cweb/Makefile
@@ -6,16 +6,22 @@
#
PORTNAME= cweb
-PORTVERSION= 3.64
+PORTVERSION= 3.64a.a
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= web/c_cpp/cweb
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/.([a-z])$/\1/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Literate programming tools for the C language
NO_WRKSUBDIR= yes
+MAKE_ARGS= CWEBINPUTS="${DATADIR}" \
+ CFLAGS="${CFLAGS}" \
+ LINKFLAGS="" \
+ CC="${CC}"
+
MAN1= cweb.1
post-patch: