aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dconf/Makefile')
-rw-r--r--devel/dconf/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/dconf/Makefile b/devel/dconf/Makefile
index 824749468101..5bb584070867 100644
--- a/devel/dconf/Makefile
+++ b/devel/dconf/Makefile
@@ -27,11 +27,14 @@ USE_GNOME= gnomehack gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_UNSAFE=yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+pre-build:
+ ${GMAKE} -C ${WRKSRC}/client dconf-client.c libdconf.so.0
+
post-install:
-${LOCALBASE}/bin/gio-querymodules ${PREFIX}/lib/gio/modules