aboutsummaryrefslogtreecommitdiff
path: root/devel/eboxy
diff options
context:
space:
mode:
Diffstat (limited to 'devel/eboxy')
-rw-r--r--devel/eboxy/Makefile18
-rw-r--r--devel/eboxy/distinfo4
-rw-r--r--devel/eboxy/files/patch-admin::ltmain.sh15
-rw-r--r--devel/eboxy/files/patch-eboxy::Makefile.in11
-rw-r--r--devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp10
-rw-r--r--devel/eboxy/files/patch-eboxy::conf.cpp10
-rw-r--r--devel/eboxy/files/patch-eboxy::interfacemanager.cpp19
-rw-r--r--devel/eboxy/files/patch-eboxy::processobject.cpp10
-rw-r--r--devel/eboxy/files/patch-eboxy::script_bison.ypp10
-rw-r--r--devel/eboxy/pkg-plist14
10 files changed, 93 insertions, 28 deletions
diff --git a/devel/eboxy/Makefile b/devel/eboxy/Makefile
index f30af2bbf20a..3264ab2f86bb 100644
--- a/devel/eboxy/Makefile
+++ b/devel/eboxy/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= eboxy
-PORTVERSION= 0.3.9
-PORTREVISION= 1
+PORTVERSION= 0.4.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,11 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Create simple GUI interfaces for entertainment PC
-USE_SDL= sdl gui
-USE_GNOME= gnometarget libxml2
+USE_BZIP2= yes
+USE_SDL= sdl gui mixer
+USE_GNOME= gnometarget libxml2 lthack
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-lirc
@@ -37,8 +37,10 @@ BROKEN= "Configure fails on ia64"
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-O2 $$CFLAGS|$$CFLAGS|g' ${WRKSRC}/configure
- @${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
- 's|malloc\.h|stdlib.h|g'
+ @${REINPLACE_CMD} -e 's|-O2 $$CFLAGS|$$CFLAGS|g ; \
+ s|-O2 $$CXXFLAGS|$$CXXFLAGS|g' ${WRKSRC}/configure
+
+pre-build:
+ @cd ${WRKSRC}/eboxy && ${SH} ./makeparser.sh
.include <bsd.port.post.mk>
diff --git a/devel/eboxy/distinfo b/devel/eboxy/distinfo
index 193f8e3d69c9..058a2caa59f0 100644
--- a/devel/eboxy/distinfo
+++ b/devel/eboxy/distinfo
@@ -1,2 +1,2 @@
-MD5 (eboxy-0.3.9.tar.gz) = 8002a233edf4b30ddf553b43c883be0a
-SIZE (eboxy-0.3.9.tar.gz) = 1053498
+MD5 (eboxy-0.4.1.tar.bz2) = ff1086e34497053d3be317a56e161791
+SIZE (eboxy-0.4.1.tar.bz2) = 815967
diff --git a/devel/eboxy/files/patch-admin::ltmain.sh b/devel/eboxy/files/patch-admin::ltmain.sh
deleted file mode 100644
index 826dfbbee27d..000000000000
--- a/devel/eboxy/files/patch-admin::ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- admin/ltmain.sh.orig Tue Oct 1 17:43:57 2002
-+++ admin/ltmain.sh Sat Nov 2 17:38:55 2002
-@@ -4746,10 +4746,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/eboxy/files/patch-eboxy::Makefile.in b/devel/eboxy/files/patch-eboxy::Makefile.in
new file mode 100644
index 000000000000..6a0a34bb2a09
--- /dev/null
+++ b/devel/eboxy/files/patch-eboxy::Makefile.in
@@ -0,0 +1,11 @@
+--- eboxy/Makefile.in.orig Thu May 20 16:46:56 2004
++++ eboxy/Makefile.in Thu May 20 21:24:26 2004
+@@ -239,7 +239,7 @@
+ INCLUDES = $(all_includes)
+
+ # the library search path.
+-eboxy_LDFLAGS = $(all_libraries) -ldl $(XML_LIBS) $(LIRC_LIBS)
++eboxy_LDFLAGS = $(all_libraries) $(XML_LIBS) $(LIRC_LIBS)
+
+ eboxy_CXXFLAGS = $(XML_CFLAGS) $(LIRC_INCLUDE)
+
diff --git a/devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp b/devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp
new file mode 100644
index 000000000000..8802cdfc0ff6
--- /dev/null
+++ b/devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp
@@ -0,0 +1,10 @@
+--- eboxy/basewidgets/stringlist.cpp.orig Thu May 20 16:46:55 2004
++++ eboxy/basewidgets/stringlist.cpp Thu May 20 20:56:53 2004
+@@ -18,6 +18,7 @@
+ #include <cstring>
+ #include <iostream>
+ #include <vector>
++#include <string>
+
+ #include "stringlist.h"
+
diff --git a/devel/eboxy/files/patch-eboxy::conf.cpp b/devel/eboxy/files/patch-eboxy::conf.cpp
new file mode 100644
index 000000000000..9fe05ab1ed08
--- /dev/null
+++ b/devel/eboxy/files/patch-eboxy::conf.cpp
@@ -0,0 +1,10 @@
+--- eboxy/conf.cpp.orig Thu May 20 16:46:55 2004
++++ eboxy/conf.cpp Thu May 20 21:23:18 2004
+@@ -19,6 +19,7 @@
+ #include "config.h"
+ #endif
+
++#include <cstdio>
+ #include <vector>
+ #include <iostream>
+ #include <fstream>
diff --git a/devel/eboxy/files/patch-eboxy::interfacemanager.cpp b/devel/eboxy/files/patch-eboxy::interfacemanager.cpp
new file mode 100644
index 000000000000..b661e3d53d63
--- /dev/null
+++ b/devel/eboxy/files/patch-eboxy::interfacemanager.cpp
@@ -0,0 +1,19 @@
+--- eboxy/interfacemanager.cpp.orig Thu May 20 16:46:55 2004
++++ eboxy/interfacemanager.cpp Thu May 20 21:22:10 2004
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+
+ #include <iostream>
++#include <cstdio>
+
+ #include "dlfcn.h"
+ #include "main.h"
+@@ -48,7 +49,7 @@
+ libhandle = dlopen(libfile, RTLD_LAZY);
+ if(libhandle == 0) {
+ // Load failed
+- char *errorstr = dlerror();
++ const char *errorstr = dlerror();
+ cerr << "InterfaceManager: Couldn't load interface plugin " << libfile << endl;
+ cerr << errorstr << endl;
+ return EBERR_DLOPEN_FAILED; // Failed to load library
diff --git a/devel/eboxy/files/patch-eboxy::processobject.cpp b/devel/eboxy/files/patch-eboxy::processobject.cpp
new file mode 100644
index 000000000000..e7afb4d2a93d
--- /dev/null
+++ b/devel/eboxy/files/patch-eboxy::processobject.cpp
@@ -0,0 +1,10 @@
+--- eboxy/processobject.cpp.orig Thu May 20 16:46:55 2004
++++ eboxy/processobject.cpp Thu May 20 21:14:22 2004
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+
+ #include <iostream>
++#include <string>
+ #include <cstring>
+ #include <cstdio>
+ #include <cstdlib>
diff --git a/devel/eboxy/files/patch-eboxy::script_bison.ypp b/devel/eboxy/files/patch-eboxy::script_bison.ypp
new file mode 100644
index 000000000000..642081169f0c
--- /dev/null
+++ b/devel/eboxy/files/patch-eboxy::script_bison.ypp
@@ -0,0 +1,10 @@
+--- eboxy/script_bison.ypp.orig Thu May 20 16:46:55 2004
++++ eboxy/script_bison.ypp Thu May 20 21:20:13 2004
+@@ -24,6 +24,7 @@
+ #include <cstring>
+ #include <cmath>
+ #include <string>
++#include <cstdio>
+ #include <cstdlib>
+ #include <iostream>
+ #include <map>
diff --git a/devel/eboxy/pkg-plist b/devel/eboxy/pkg-plist
index 0e62920dd19e..f51f7205b66d 100644
--- a/devel/eboxy/pkg-plist
+++ b/devel/eboxy/pkg-plist
@@ -2,9 +2,17 @@ bin/eboxy
include/eboxy/eboxyplugin.h
include/eboxy/pluginconstants.h
include/eboxy/plugintypes.h
-lib/eboxy/filebrowser.so
+lib/eboxy/libbasewidgets.a
+lib/eboxy/libbasewidgets.so
+lib/eboxy/libbasewidgets.so.0
+lib/eboxy/plugins/generic/filebrowser.so
+lib/eboxy/plugins/generic/simplemusic.so
+lib/eboxy/plugins/interface/libsdl_gui.so
lib/libeboxyplugin.a
-share/eboxy/eboxy.dtd
-@dirrm share/eboxy
+%%DATADIR%%/eboxy.dtd
+@dirrm %%DATADIR%%
+@dirrm lib/eboxy/plugins/interface
+@dirrm lib/eboxy/plugins/generic
+@dirrm lib/eboxy/plugins
@dirrm lib/eboxy
@dirrm include/eboxy