aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-file/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ecore-file/Makefile')
-rw-r--r--devel/ecore-file/Makefile48
1 files changed, 24 insertions, 24 deletions
diff --git a/devel/ecore-file/Makefile b/devel/ecore-file/Makefile
index dd666eaa26f6..9372c81162cb 100644
--- a/devel/ecore-file/Makefile
+++ b/devel/ecore-file/Makefile
@@ -6,55 +6,55 @@
#
PORTNAME= file
-PORTVERSION= 0.9.9.042
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+PORTREVISION= 0
+CATEGORIES= devel enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (file module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_file
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS= --disable-ecore-con \
- --disable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --enable-ecore-file \
- --disable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --disable-ecore-x \
- --disable-ecore-imf \
- --disable-ecore-imf_evas
+.include <../ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-file
OPTIONS= CURL "Enable Curl support" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_CURL)
-CONFIGURE_ARGS+= --enable-curl
+USE_EFL_ECORE= con
+CONFIGURE_ARGS+= --enable-ecore-con \
+ --enable-curl
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --disable-curl
.endif
post-patch:
- @${REINPLACE_CMD} -E -e \
- 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
-e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
${BUILD_WRKSRC}/Makefile.in
+.if !defined(WITHOUT_CURL)
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/libecore_con\.la,-lecore_con,'\
+ ${BUILD_WRKSRC}/Makefile.in
+.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/ecore-file.pc \