aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-main/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ecore-main/Makefile')
-rw-r--r--devel/ecore-main/Makefile32
1 files changed, 29 insertions, 3 deletions
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
index 099a1be9e2d2..373ad9224b53 100644
--- a/devel/ecore-main/Makefile
+++ b/devel/ecore-main/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= main
-DISTVERSION= 1.0.1
+DISTVERSION= 1.1.0
CATEGORIES= devel enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-05-25/base/
+ http://files.roorback.net/e17/2011-12-02/base/
PKGNAMEPREFIX= ecore-
DISTNAME= ecore-${DISTVERSION}
@@ -17,15 +17,41 @@ MAINTAINER= magik@roorback.net
COMMENT= Enlightenment core abstraction library (main library)
LICENSE= BSD
+
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_EFL= eina libtool_hack
-USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig
USE_ICONV= yes
USE_LDCONFIG= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/ecore
+
.include "Makefile.inc"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+CONFIGURE_ARGS+= --enable-install-examples
+.else
+CONFIGURE_ARGS+= --disable-install-examples
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|= \$$(datadir)/\$$(PACKAGE)/examples|= $$(datadir)/examples/$$(PACKAGE)|' \
+ ${WRKSRC}/src/examples/Makefile.in
+
+post-install:
+.if defined(NOPORTEXAMPLES)
+ @${RMDIR} ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>