aboutsummaryrefslogtreecommitdiff
path: root/devel/elf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/elf/Makefile')
-rw-r--r--devel/elf/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/elf/Makefile b/devel/elf/Makefile
index acb66764464d..f2ff574b8597 100644
--- a/devel/elf/Makefile
+++ b/devel/elf/Makefile
@@ -3,14 +3,16 @@
PORTNAME= elf
PORTVERSION= 0.5.4p1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_PACKETSTORM}
-MASTER_SITE_SUBDIR= linux/reverse-engineering
+MASTER_SITES= PACKETSTORM/linux/reverse-engineering
MAINTAINER= ports@FreeBSD.org
COMMENT= Commandline based ELF header analyzer
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= gmake readline
GNU_CONFIGURE= yes
PLIST_FILES= bin/elf man/man1/elf.1.gz
@@ -21,4 +23,7 @@ post-patch:
do-build:
${DO_MAKE_BUILD} -C ${WRKSRC}/src
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
.include <bsd.port.mk>