aboutsummaryrefslogtreecommitdiff
path: root/devel/gauche-readline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gauche-readline/Makefile')
-rw-r--r--devel/gauche-readline/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/gauche-readline/Makefile b/devel/gauche-readline/Makefile
new file mode 100644
index 000000000000..19ee95b2a590
--- /dev/null
+++ b/devel/gauche-readline/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Gauche Readline
+# Date created: 15 Jan 2004
+# Whom: Erik Greenwald <erik@smluc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= readline
+PORTVERSION= 0.1
+CATEGORIES= devel scheme
+MASTER_SITES= http://www.shiro.dreamhost.com/scheme/vault/
+PKGNAMEPREFIX= gauche-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= gauche
+
+MAINTAINER= erik@smluc.org
+COMMENT= A pure gauche/scheme implementation of the Readline library
+
+RUN_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+BUILD_DEPENDS= gauche-config:${PORTSDIR}/lang/gauche
+
+.include <bsd.port.pre.mk>
+GAUCHE_CONFIG= ${LOCALBASE}/bin/gauche-config
+GAUCHE_LIBDIR= ${GAUCHE_CONFIG} --sitelibdir
+PLIST_SUB+= GAUCHE_LIBDIR=${GAUCHE_LIBDIR:S/${LOCALBASE}\///}
+
+do-install:
+ @${CP} -r ${WRKSRC}/readline* ${GAUCHE_LIBDIR}
+
+.include <bsd.port.post.mk>