aboutsummaryrefslogtreecommitdiff
path: root/devel/gaul/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gaul/Makefile')
-rw-r--r--devel/gaul/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/gaul/Makefile b/devel/gaul/Makefile
index 0ac4a83d7562..c6d52cb9aba2 100644
--- a/devel/gaul/Makefile
+++ b/devel/gaul/Makefile
@@ -10,16 +10,15 @@ PORTNAME= gaul
PORTVERSION= 0.1849.0
PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-devel-${PORTVERSION:R}-${PORTVERSION:E}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Genetic Algorithm Utility Library
-LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= automake:19 libtool:15
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -30,4 +29,7 @@ USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread||g' ${WRKSRC}/configure
+run-autotools::
+ (cd ${WRKSRC} ; ${ACLOCAL} ; ${AUTOMAKE})
+
.include <bsd.port.mk>