aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gconf/Makefile')
-rw-r--r--devel/gconf/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index b1966b2f565a..0942f6960dd9 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -16,28 +16,21 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile \
- oaf.0:${PORTSDIR}/devel/oaf \
db3.2:${PORTSDIR}/databases/db3
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack glib12 gtk12 oaf libxml orbit
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-post-install:
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/schemas/apps
.include <bsd.port.mk>