aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb66/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gdb66/Makefile')
-rw-r--r--devel/gdb66/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 4a182f499c64..b5275c1ae4f7 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,6 +27,19 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-suffix=6
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.endif
+.if ${ARCH} == "amd64" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+PLIST_SUB+= NO_NATIVE_GDB=""
+post-install:
+ cd ${PREFIX}/bin ; ${LN} -sf gdb${PORTVERSION} gdb
+.else
+PLIST_SUB+= NO_NATIVE_GDB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/$$/ [FreeBSD]/' ${WRKSRC}/gdb/version.in
@@ -45,8 +58,4 @@ cklatest:
ftp://sources.redhat.com/pub/${MASTER_SITE_SUBDIR}/ \
| ${GREP} gdb+dejagnu-weekly
-.include <bsd.port.mk>
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.endif
+.include <bsd.port.post.mk>