aboutsummaryrefslogtreecommitdiff
path: root/devel/geany-plugin-vc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/geany-plugin-vc/Makefile')
-rw-r--r--devel/geany-plugin-vc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/geany-plugin-vc/Makefile b/devel/geany-plugin-vc/Makefile
new file mode 100644
index 000000000000..f606257199bb
--- /dev/null
+++ b/devel/geany-plugin-vc/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= geany-plugin
+PORTVERSION= ${GEANY_VER}
+CATEGORIES= devel
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
+
+GEANY_PLUGIN= vc
+GEANY_PLUGIN_DIR= geanyvc
+
+OPTIONS_DEFINE= GTKSPELL
+OPTIONS_DEFAULT= GTKSPELL
+GTKSPELL_DESC= Spell checking support via GtkSpell
+
+.include "${.CURDIR}/../geany-plugins/files/Makefile.common"
+# bsd.port.options.mk is already included
+
+.if ${PORT_OPTIONS:MGTKSPELL}
+LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
+CONFIGURE_ARGS+= --enable-gtkspell
+.else
+CONFIGURE_ARGS+= --disable-gtkspell
+.endif
+
+.include <bsd.port.mk>