aboutsummaryrefslogtreecommitdiff
path: root/devel/gettext/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gettext/Makefile')
-rw-r--r--devel/gettext/Makefile41
1 files changed, 37 insertions, 4 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index c9c2776b1eef..56e1cbec1c33 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -6,27 +6,60 @@
#
PORTNAME= gettext
-PORTVERSION= 0.10.35
-PORTREVISION= 1
+PORTVERSION= 0.10.40
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gettext
-MAINTAINER= reg@FreeBSD.org
+MAINTAINER= sobomax@FreeBSD.org
-USE_LIBTOOL= yes
+LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
+
+NO_LATEST_LINK= yes
+
+USE_BISON= yes
INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
+MAN3= bind_textdomain_codeset.3 bindtextdomain.3 dcgettext.3 \
+ dcngettext.3 dgettext.3 dngettext.3 gettext.3 ngettext.3 \
+ textdomain.3
+
+# X X X - I know, but it doesn't work with BSD iconv yet. :(((
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e \
+ 's|-liconv|-lgiconv|g ; s|iconv\.h|giconv\.h|g'
+
pre-configure:
${RM} ${WRKSRC}/doc/gettext.info*
+.if !defined(WANT_FULL_GETTEXT)
+BINFILES= gettext msgcmp msgcomm msgfmt msgmerge msgunfmt \
+ ngettext xgettext
+PLIST= ${WRKDIR}/PLIST
+CONFIGURE_ARGS= --disable-shared
+.undef MAN3
+.undef INSTALLS_SHLIB
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/misc/gettextize \
+ ${PREFIX}/bin/gettextize-new
+ @${ECHO_CMD} bin/gettextize-new > ${WRKDIR}/PLIST
+.for file in ${BINFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${file} ${PREFIX}/bin/${file}-new
+ @${ECHO_CMD} bin/${file}-new >> ${WRKDIR}/PLIST
+.endfor
+.else
post-install:
@install-info ${PREFIX}/info/gettext.info ${PREFIX}/info/dir
${MKDIR} ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/misc/po-mode.el \
${PREFIX}/share/emacs/site-lisp/po-mode.el
${MKDIR} ${X11BASE}/share/locale
+.endif
.include <bsd.port.mk>