aboutsummaryrefslogtreecommitdiff
path: root/devel/glade/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glade/Makefile')
-rw-r--r--devel/glade/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/glade/Makefile b/devel/glade/Makefile
new file mode 100644
index 000000000000..bf8defae4f36
--- /dev/null
+++ b/devel/glade/Makefile
@@ -0,0 +1,39 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/devel/glade/Makefile 19813 2014-08-15 19:44:33Z gusi $
+
+PORTNAME= glade
+PORTVERSION= 3.18.3
+PORTREVISION= 1
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= User interface builder for GTK+ 3
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+
+CONFLICTS= glade3-3.*
+
+USES= desktop-file-utils gettext gmake libtool \
+ pathfix pkgconfig tar:xz
+USE_GNOME= gtk30 gnomeprefix gnomedocutils intlhack \
+ introspection:build
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+DOCSDIR= ${PREFIX}/share/doc/gladeui-2
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT=PYTHON
+PYTHON_CONFIGURE_ENABLE= python
+PYTHON_USES= python:3
+PYTHON_USE= GNOME=py3gobject3
+
+.include <bsd.port.mk>