aboutsummaryrefslogtreecommitdiff
path: root/devel/glade2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glade2/Makefile')
-rw-r--r--devel/glade2/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index cbf755a0f200..46540636d01a 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -13,17 +13,22 @@ MASTER_SITE_SUBDIR= stable/sources/glade
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
FETCH_BEFORE_ARGS= -b
USE_X_PREFIX= yes
+USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/libs"
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+ s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/\@PACKAGE\@|\$\(prefix\)/share/\@PACKAGE\@|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>