aboutsummaryrefslogtreecommitdiff
path: root/devel/glade2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glade2/Makefile')
-rw-r--r--devel/glade2/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index 192f25fcb4eb..b13e9f594168 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -1,23 +1,27 @@
# New ports collection makefile for: glade
-# Version required: 0.3.7
+# Version required: 0.4.1
# Date created: 29 June 1998
# Whom: Dom Mitchell <dom@myrddin.demon.co.uk>
#
-# $Id: Makefile,v 1.10 1998/11/18 17:35:16 vanilla Exp $
+# $Id: Makefile,v 1.11 1999/03/19 04:39:47 nectar Exp $
#
-DISTNAME= glade-0.3.7
+DISTNAME= glade-0.4.1
CATEGORIES= devel
MASTER_SITES= http://glade.pn.org/
MAINTAINER= dom@myrddin.demon.co.uk
-LIB_DEPENDS= gtk11.1:${PORTSDIR}/x11-toolkits/gtk11 \
- intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11-config"
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --disable-gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/libs"
post-install:
.if !defined(NOPORTDOCS)