aboutsummaryrefslogtreecommitdiff
path: root/devel/glade3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glade3/Makefile')
-rw-r--r--devel/glade3/Makefile30
1 files changed, 21 insertions, 9 deletions
diff --git a/devel/glade3/Makefile b/devel/glade3/Makefile
index 709288bd77b6..4d851505e4f9 100644
--- a/devel/glade3/Makefile
+++ b/devel/glade3/Makefile
@@ -3,11 +3,11 @@
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/glade3/Makefile,v 1.21 2006/10/08 19:17:28 mezz Exp $
+# $MCom: ports/devel/glade3/Makefile,v 1.29 2007/03/13 17:16:00 mezz Exp $
#
PORTNAME= glade3
-PORTVERSION= 3.0.3
+PORTVERSION= 3.2.0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -20,28 +20,40 @@ INSTALLS_ICONS= yes
USE_XLIB= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 libxml2 gnomeprefix gnomehack
+USE_GNOME= gnometarget gtk20 libxml2 gnomeprefix gnomehack \
+ gnomedocutils desktopfileutils
WANT_GNOME= yes
USE_GETTEXT= yes
+INSTALLS_OMF= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-DOCSDIR= share/doc/gladeui
+DOCSDIR= ${PREFIX}/share/doc/gladeui
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not build on 4.X
-.endif
-
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
CONFIGURE_ARGS+=--enable-gnome
-PKGNAMESUFFIX:= -gnome
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gnome
.else
CONFIGURE_ARGS+=--disable-gnome
.endif
+.if ${HAVE_GNOME:Mpygtk2}!=""
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygtk2
+PLIST_SUB+= PYTHON:=""
+.else
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON:="@comment "
+.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/lib/glade3/bindings
+ @-update-desktop-database
+
.include <bsd.port.post.mk>