aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glib20/Makefile')
-rw-r--r--devel/glib20/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 0964225a4421..d43f0ff2e151 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -3,12 +3,12 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/devel/glib20/Makefile,v 1.1 2007/11/30 18:48:03 marcus Exp $
+# $MCom: ports/devel/glib20/Makefile,v 1.117 2008/03/19 04:44:58 marcus Exp $
#
PORTNAME= glib
-PORTVERSION= 2.14.6
-PORTREVISION?= 0
+PORTVERSION= 2.16.1
+PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/},} \
ftp://ftp.gtk.org/pub/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/ \
@@ -35,11 +35,13 @@ USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget pkgconfig ltverhack
USE_GMAKE= yes
+USE_PYTHON= yes
USE_PERL5= yes
CONFIGURE_ARGS= --enable-static --with-libiconv=gnu \
--disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
--disable-man --without-xml-catalog \
- --with-pcre=system
+ --with-pcre=system \
+ --disable-fam
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -59,10 +61,6 @@ GLIB_ARCH= ${ARCH}
.endif
CONFIGURE_TARGET= --build=${GLIB_ARCH}-portbld-freebsd${OSREL}
-.if ( ( ${OSVERSION} < 504101 ) || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600012 ) )
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gthread_gthread-posix.c
-.endif
-
.if defined(WITH_COLLATION_FIX)
LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-glib_Makefile.in \