aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glib20/Makefile')
-rw-r--r--devel/glib20/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 2cc782eaaa97..c15173748ead 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -8,7 +8,7 @@
PORTNAME= glib
PORTVERSION= 2.12.7
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/},} \
ftp://ftp.gtk.org/pub/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/ \
@@ -46,6 +46,16 @@ OPTIONS= COLLATION_FIX "fix string collation" off
.include <bsd.port.pre.mk>
+# Let glib use asm code for implementing atomic ops on i386 and amd64.
+.if ${ARCH} == "i386"
+GLIB_ARCH= i486
+.elif ${ARCH} == "amd64"
+GLIB_ARCH= x86_64
+.else
+GLIB_ARCH= ${ARCH}
+.endif
+CONFIGURE_TARGET= --build=${GLIB_ARCH}-portbld-freebsd${OSREL}
+
.if ( ( ${OSVERSION} < 504101 ) || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600012 ) )
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gthread_gthread-posix.c
.endif