aboutsummaryrefslogtreecommitdiff
path: root/devel/glibmm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glibmm/Makefile')
-rw-r--r--devel/glibmm/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/devel/glibmm/Makefile b/devel/glibmm/Makefile
index 497fbb839b46..239859a071f6 100644
--- a/devel/glibmm/Makefile
+++ b/devel/glibmm/Makefile
@@ -16,10 +16,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ interfaces for glib2
+USE_BZIP2= yes
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 1
+
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4
USE_GNOME= gnomehack gnometarget glib20
@@ -31,14 +36,14 @@ CONFIGURE_ARGS= --enable-static
PLIST_SUB= VERSION="2.4" API_VERSION="2.4"
post-patch:
- @${REINPLACE_CMD} -e '/^SUBDIRS = /s/tests//' ${WRKSRC}/Makefile.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -E '/^SUBDIRS = /s/(docs|examples)//g' ${WRKSRC}/Makefile.in
-.endif
+.for d in docs examples tests
+ @${REINPLACE_CMD} -e '/^SUBDIRS = /s/${d}//' ${WRKSRC}/Makefile.in
+.endfor
-.if !defined(NOPORTDOCS)
-post-configure:
- @${TOUCH} ${WRKSRC}/docs/reference/html/index.html
-.endif
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/docs/reference/beautify_docs.pl \
+ ${PREFIX}/lib/glibmm-2.4/proc
.include <bsd.port.mk>
+
+.endif