aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnome-vfs/Makefile')
-rw-r--r--devel/gnome-vfs/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
new file mode 100644
index 000000000000..84a44acaa666
--- /dev/null
+++ b/devel/gnome-vfs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnomevfs
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomevfs
+PORTVERSION= 0.1
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gnome-vfs
+DISTNAME= gnome-vfs-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALL_SHLIBS= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --disable-gconf
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>