aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile4
-rw-r--r--devel/gnome-vfs/distinfo6
-rw-r--r--devel/gnome-vfs/files/patch-configure52
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-address.c10
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c10
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h17
-rw-r--r--devel/gnome-vfs/files/patch-modules_file-method.c12
-rw-r--r--devel/gnome-vfs/pkg-deinstall.in2
-rw-r--r--devel/gnome-vfs/pkg-install.in2
-rw-r--r--devel/gnome-vfs/pkg-plist3
10 files changed, 26 insertions, 92 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 868416ce464d..b43a31ab1af4 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -3,11 +3,11 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/Makefile,v 1.160 2006/10/07 15:04:44 marcus Exp $
+# $MCom: ports/devel/gnome-vfs/Makefile,v 1.167 2007/03/13 13:02:20 ahze Exp $
#
PORTNAME= gnome-vfs
-PORTVERSION= 2.16.3
+PORTVERSION= 2.18.0.1
PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
diff --git a/devel/gnome-vfs/distinfo b/devel/gnome-vfs/distinfo
index d2ccd4ab0fb2..86b8fafcbd8a 100644
--- a/devel/gnome-vfs/distinfo
+++ b/devel/gnome-vfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-vfs-2.16.3.tar.bz2) = 586d6fe3740385c000a864d5e2cf8215
-SHA256 (gnome2/gnome-vfs-2.16.3.tar.bz2) = 657df4d40dd1c8cbc9a266b9f38fea36019ef8a917eafcd3c38c840b8e9c7777
-SIZE (gnome2/gnome-vfs-2.16.3.tar.bz2) = 1900424
+MD5 (gnome2/gnome-vfs-2.18.0.1.tar.bz2) = 0b7a6ab495c0d94c3db00a7b0321adbf
+SHA256 (gnome2/gnome-vfs-2.18.0.1.tar.bz2) = 9e881e9f9ea4fb8d1d55c804b55829ac3b349b0b8a5c11e66dee44898acc3227
+SIZE (gnome2/gnome-vfs-2.18.0.1.tar.bz2) = 1830575
diff --git a/devel/gnome-vfs/files/patch-configure b/devel/gnome-vfs/files/patch-configure
index 75ee29e9730b..df7bc5e67603 100644
--- a/devel/gnome-vfs/files/patch-configure
+++ b/devel/gnome-vfs/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig Tue Nov 7 04:08:31 2006
-+++ configure Mon Nov 20 10:52:37 2006
-@@ -21984,6 +21984,8 @@
+--- configure.orig Mon Feb 12 14:15:37 2007
++++ configure Mon Feb 12 14:15:37 2007
+@@ -5708,7 +5708,7 @@ fi
+
+
+ for ac_header in sys/types.h sys/stat.h stdlib.h string.h memory.h strings.h \
+- inttypes.h stdint.h unistd.h
++ inttypes.h stdint.h unistd.h sys/sysmacros.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for $ac_header" >&5
+@@ -22101,6 +22101,8 @@ echo $ECHO_N "checking for LC_MESSAGES..
if test "${am_cv_val_LC_MESSAGES+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -9,7 +18,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -22030,6 +22032,7 @@
+@@ -22147,6 +22149,7 @@ am_cv_val_LC_MESSAGES=no
fi
rm -f conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
@@ -17,7 +26,7 @@
fi
echo "$as_me:$LINENO: result: $am_cv_val_LC_MESSAGES" >&5
echo "${ECHO_T}$am_cv_val_LC_MESSAGES" >&6
-@@ -23495,6 +23498,7 @@
+@@ -23612,6 +23615,7 @@ if test `eval echo '${'$as_ac_var'}'` =
cat >>confdefs.h <<_ACEOF
#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
_ACEOF
@@ -25,16 +34,7 @@
have_ngettext=yes
else
echo "$as_me:$LINENO: checking for ngettext in -lintl" >&5
-@@ -24892,7 +24896,7 @@
-
-
-
--for ac_header in mntent.h sys/mnttab.h sys/vfstab.h sys/cdio.h sys/mount.h sys/mntctl.h sys/vfs.h sys/vmount.h sys/sysctl.h fstab.h fnmatch.h
-+for ac_header in mntent.h sys/mnttab.h sys/vfstab.h sys/cdio.h sys/mount.h sys/mntctl.h sys/vfs.h sys/vmount.h sys/sysctl.h fstab.h fnmatch.h sys/sysmacros.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -33245,7 +33249,7 @@
+@@ -33364,7 +33368,7 @@ if test "${openssl_libs+set}" = set; the
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -43,7 +43,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -33543,7 +33547,7 @@
+@@ -33662,7 +33666,7 @@ if test "${openssl_libs+set}" = set; the
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -52,23 +52,3 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -39124,6 +39128,9 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+#ifdef HAVE_SYS_PARAM_H
-+#include <sys/param.h>
-+#endif
- #include <sys/statfs.h>
- #include <sys/fstyp.h>
- _ACEOF
-@@ -39165,6 +39172,9 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+#ifdef HAVE_SYS_PARAM_H
-+#include <sys/param.h>
-+#endif
- #include <sys/statfs.h>
- #include <sys/vmount.h>
- _ACEOF
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-address.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-address.c
deleted file mode 100644
index 1636ca99d4df..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-address.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libgnomevfs/gnome-vfs-address.c.orig Wed Apr 12 10:16:28 2006
-+++ libgnomevfs/gnome-vfs-address.c Thu Apr 20 09:52:12 2006
-@@ -32,6 +32,7 @@
- #include <sys/types.h>
-
- #ifndef G_OS_WIN32
-+#include <sys/socket.h>
- #include <sys/select.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c
index 5260a0f3ec76..f50e1cb819b8 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c
@@ -1,15 +1,5 @@
--- libgnomevfs/gnome-vfs-hal-mounts.c.orig Mon Aug 7 04:16:27 2006
+++ libgnomevfs/gnome-vfs-hal-mounts.c Sun Sep 17 17:39:48 2006
-@@ -32,7 +32,9 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/stat.h>
-+#ifdef HAVE_SYS_SYSMACROS_H
- #include <sys/sysmacros.h>
-+#endif
- #include <sys/types.h>
- #include <unistd.h>
- #include <limits.h>
@@ -627,20 +629,30 @@ _hal_volume_policy_check (GnomeVFSVolume
"/",
"/bin",
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h
deleted file mode 100644
index 218578c258b7..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- libgnomevfs/xdgmime.h.orig Sat Oct 7 10:42:32 2006
-+++ libgnomevfs/xdgmime.h Sat Oct 7 11:01:57 2006
-@@ -52,11 +52,14 @@ typedef void (*XdgMimeDestroy) (void *u
- #define xdg_mime_get_mime_type_from_file_name XDG_ENTRY(get_mime_type_from_file_name)
- #define xdg_mime_is_valid_mime_type XDG_ENTRY(is_valid_mime_type)
- #define xdg_mime_mime_type_equal XDG_ENTRY(mime_type_equal)
-+#define _xdg_mime_mime_type_equal XDG_ENTRY(mime_type_equal_p)
- #define xdg_mime_media_type_equal XDG_ENTRY(media_type_equal)
- #define xdg_mime_mime_type_subclass XDG_ENTRY(mime_type_subclass)
-+#define _xdg_mime_mime_type_subclass XDG_ENTRY(mime_type_subclass_p)
- #define xdg_mime_get_mime_parents XDG_ENTRY(get_mime_parents)
- #define xdg_mime_list_mime_parents XDG_ENTRY(list_mime_parents)
- #define xdg_mime_unalias_mime_type XDG_ENTRY(unalias_mime_type)
-+#define _xdg_mime_unalias_mime_type XDG_ENTRY(unalias_mime_type_p)
- #define xdg_mime_get_max_buffer_extents XDG_ENTRY(get_max_buffer_extents)
- #define xdg_mime_shutdown XDG_ENTRY(shutdown)
- #define xdg_mime_dump XDG_ENTRY(dump)
diff --git a/devel/gnome-vfs/files/patch-modules_file-method.c b/devel/gnome-vfs/files/patch-modules_file-method.c
deleted file mode 100644
index dbb237226e99..000000000000
--- a/devel/gnome-vfs/files/patch-modules_file-method.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- modules/file-method.c.orig Sun May 22 23:30:16 2005
-+++ modules/file-method.c Sun May 22 23:31:08 2005
-@@ -66,6 +66,9 @@
- #if HAVE_SYS_VFS_H
- #include <sys/vfs.h>
- #elif HAVE_SYS_MOUNT_H
-+#if HAVE_SYS_PARAM_H
-+#include <sys/param.h>
-+#endif
- #include <sys/mount.h>
- #endif
-
diff --git a/devel/gnome-vfs/pkg-deinstall.in b/devel/gnome-vfs/pkg-deinstall.in
index d1783a46cd02..f920c5742ca1 100644
--- a/devel/gnome-vfs/pkg-deinstall.in
+++ b/devel/gnome-vfs/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.10 2006/07/22 20:45:37 mezz Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.12 2006/12/18 12:34:11 ahze Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-install.in b/devel/gnome-vfs/pkg-install.in
index 98e90d3db5f0..ff583b731c6d 100644
--- a/devel/gnome-vfs/pkg-install.in
+++ b/devel/gnome-vfs/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.10 2006/07/22 20:45:37 mezz Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.12 2006/12/18 12:34:11 ahze Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-plist b/devel/gnome-vfs/pkg-plist
index 6e36ede178f5..dca70b75435a 100644
--- a/devel/gnome-vfs/pkg-plist
+++ b/devel/gnome-vfs/pkg-plist
@@ -145,6 +145,7 @@ share/locale/it/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ja/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ka/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ko/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/ku/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/li/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/lt/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/lv/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -233,6 +234,8 @@ share/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrmtry share/locale/mg
@dirrmtry share/locale/li/LC_MESSAGES
@dirrmtry share/locale/li
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
@dirrmtry share/locale/ko/LC_MESSAGES
@dirrmtry share/locale/ko
@dirrmtry share/locale/gl/LC_MESSAGES