aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomebuild
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnomebuild')
-rw-r--r--devel/gnomebuild/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 64121dfa33ff..478587cd2120 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -24,6 +24,7 @@ USE_GNOME= gnomeprefix gnomehack gnometarget libgnomeui gnomevfs2
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-compile-warnings=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnuregex"
@@ -31,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.if ${OSVERSION} >= 500000
EXTRA_PATCHES+= ${FILESDIR}/current-src_backends_libgbf_am_gbf-am-project.c
-.else
+.elif ${ARCH} != "i386"
EXTRA_PATCHES+= ${FILESDIR}/stable-src_backends_libgbf_am_gbf-am-project.c
.endif