aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomevfs2
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnomevfs2')
-rw-r--r--devel/gnomevfs2/Makefile31
-rw-r--r--devel/gnomevfs2/distinfo4
-rw-r--r--devel/gnomevfs2/files/patch-aa22
-rw-r--r--devel/gnomevfs2/files/patch-ac36
-rw-r--r--devel/gnomevfs2/files/patch-gnome-vfs-2.0.pc.in7
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_eggdirfuncs.c11
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-mime-info.c11
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-resolve.c13
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c45
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-utils.c25
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c16
-rw-r--r--devel/gnomevfs2/files/patch-modules_default-modules.conf12
-rw-r--r--devel/gnomevfs2/files/patch-modules_extfs-method.c11
-rw-r--r--devel/gnomevfs2/pkg-plist83
14 files changed, 171 insertions, 156 deletions
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index e608355897ea..bbdac7cff117 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomevfs2
-PORTVERSION= 2.6.2
-PORTREVISION= 1
+PORTVERSION= 2.8.3
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-vfs/2.6
+MASTER_SITE_SUBDIR= sources/gnome-vfs/2.8
DISTNAME= gnome-vfs-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -27,13 +26,17 @@ USE_GNOME= gnomeprefix gnomehack gnomehier intlhack gnomemimedata gconf2 \
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --disable-openssl \
+CONFIGURE_ARGS= --enable-openssl \
--disable-gnutls \
--with-gtk=no
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
+GCONF_SCHEMAS= desktop_default_applications.schemas \
+ desktop_gnome_url_handlers.schemas system_dns_sd.schemas \
+ system_http_proxy.schemas system_smb.schemas
+
OPTIONS= KDE_MENUS "Integrated KDE menu picks" on
.include <bsd.port.pre.mk>
@@ -41,6 +44,8 @@ OPTIONS= KDE_MENUS "Integrated KDE menu picks" on
.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
.undef WITHOUT_CDPARANOIA
.undef WITHOUT_SAMBA
+.undef WITHOUT_MDNS
+WITH_MDNS= yes
WITH_CDPARANOIA= yes
WITH_SAMBA= yes
.endif
@@ -60,6 +65,10 @@ WITH_CDPARANOIA= yes
WITH_SAMBA= yes
.endif
+.if exists(${LOCALBASE}/lib/libhowl.so)
+WITH_MDNS= yes
+.endif
+
.if defined(WITH_CDPARANOIA)
LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
PLIST_SUB+= CDPARANOIA=""
@@ -67,10 +76,14 @@ PLIST_SUB+= CDPARANOIA=""
PLIST_SUB+= CDPARANOIA="@comment "
.endif
-.if exists(${LOCALBASE}/lib/libfam) || !defined(WITHOUT_FAM)
+.if exists(${LOCALBASE}/lib/libfam.so) || !defined(WITHOUT_FAM)
LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
.endif
+.if exists(${LOCALBASE}/lib/libkrb5.so)
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
+.endif
+
.if defined(WITH_SAMBA)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
PLIST_SUB+= SAMBA=""
@@ -78,6 +91,10 @@ PLIST_SUB+= SAMBA=""
PLIST_SUB+= SAMBA="@comment "
.endif
+.if defined(WITH_MDNS)
+LIB_DEPENDS+= howl:${PORTSDIR}/net/howl
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*info.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|\@datadir\@/gnome|\@datadir\@|g'
@@ -86,7 +103,9 @@ post-patch:
${WRKSRC}/modules/vfolder/applications-all-users.vfolder-info.in
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/libgnomevfs/xdgmime.c
+ ${WRKSRC}/libgnomevfs/xdgmime.c \
+ ${WRKSRC}/libgnomevfs/eggdirfuncs.c \
+ ${WRKSRC}/libgnomevfs/gnome-vfs-mime-info.c
.if !defined(WITHOUT_KDE_MENUS)
@${SED} -e 's|/usr/local|${LOCALBASE}|g' \
< ${FILESDIR}/KDE.directory > ${WRKSRC}/KDE.directory
diff --git a/devel/gnomevfs2/distinfo b/devel/gnomevfs2/distinfo
index d88c0954602a..026296e07214 100644
--- a/devel/gnomevfs2/distinfo
+++ b/devel/gnomevfs2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-vfs-2.6.2.tar.bz2) = 61bf3e145652089c63edd423ecbc9eba
-SIZE (gnome2/gnome-vfs-2.6.2.tar.bz2) = 1372181
+MD5 (gnome2/gnome-vfs-2.8.3.tar.bz2) = 5484694e7250c80a231cfc525d924cc3
+SIZE (gnome2/gnome-vfs-2.8.3.tar.bz2) = 1907154
diff --git a/devel/gnomevfs2/files/patch-aa b/devel/gnomevfs2/files/patch-aa
index f7ec12a89ea7..caf6411ffeaa 100644
--- a/devel/gnomevfs2/files/patch-aa
+++ b/devel/gnomevfs2/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.orig Thu Aug 12 19:59:11 2004
-+++ configure Thu Aug 12 19:59:11 2004
-@@ -22922,6 +22922,8 @@
+--- configure.orig Tue Jun 1 03:53:13 2004
++++ configure Tue Jun 1 03:53:13 2004
+@@ -22815,6 +22815,8 @@
if eval "test \"\${$as_ac_var+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -9,7 +9,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -23004,6 +23006,7 @@
+@@ -22897,6 +22899,7 @@
fi
rm -f conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
@@ -17,7 +17,7 @@
fi
echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_var'}'`" >&5
echo "${ECHO_T}`eval echo '${'$as_ac_var'}'`" >&6
-@@ -23011,6 +23014,7 @@
+@@ -22904,6 +22907,7 @@
cat >>confdefs.h <<_ACEOF
#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
_ACEOF
@@ -25,7 +25,7 @@
have_ngettext=yes
else
echo "$as_me:$LINENO: checking for ngettext in -lintl" >&5
-@@ -26981,8 +26985,8 @@
+@@ -26876,8 +26880,8 @@
done
fi
@@ -36,7 +36,7 @@
if test "${ac_cv_lib_bz2_bzCompressInit+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
-@@ -27001,11 +27005,11 @@
+@@ -26896,11 +26900,11 @@
#endif
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
@@ -50,7 +50,7 @@
;
return 0;
}
-@@ -28136,7 +28140,7 @@
+@@ -28031,7 +28035,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -59,7 +59,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -29765,6 +29769,9 @@
+@@ -29660,6 +29664,9 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@@ -69,7 +69,7 @@
#include <sys/statfs.h>
#include <sys/fstyp.h>
_ACEOF
-@@ -29805,6 +29812,9 @@
+@@ -29700,6 +29707,9 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@@ -79,7 +79,7 @@
#include <sys/statfs.h>
#include <sys/vmount.h>
_ACEOF
-@@ -31432,6 +31442,7 @@
+@@ -31338,6 +31348,7 @@
s,@ORBIT_IDL@,$ORBIT_IDL,;t t
s,@BONOBO_IDLDIR@,$BONOBO_IDLDIR,;t t
s,@WARN_CFLAGS@,$WARN_CFLAGS,;t t
diff --git a/devel/gnomevfs2/files/patch-ac b/devel/gnomevfs2/files/patch-ac
index 5a687e11a977..9362cac1715f 100644
--- a/devel/gnomevfs2/files/patch-ac
+++ b/devel/gnomevfs2/files/patch-ac
@@ -1,16 +1,7 @@
---- modules/Makefile.in.orig Thu Aug 26 20:51:38 2004
-+++ modules/Makefile.in Thu Aug 26 21:00:56 2004
-@@ -195,7 +195,7 @@
- am__quote = @am__quote@
- install_sh = @install_sh@
- NULL =
--SUBDIRS = extfs vfolder
-+SUBDIRS = vfolder
-
- INCLUDES = \
- -I$(top_srcdir) \
-@@ -240,13 +240,12 @@
- @BUILD_CDEMENU_MODULE_TRUE@CDEMENU_LTLIBS = libcdemenu-desktop.la
+--- modules/Makefile.in.orig Tue May 6 15:39:48 2003
++++ modules/Makefile.in Tue May 6 15:41:28 2003
+@@ -210,7 +210,7 @@
+ @BUILD_CDEMENU_MODULE_TRUE@CDEMENU_LTLIBS = @BUILD_CDEMENU_MODULE_TRUE@libcdemenu-desktop.la
@BUILD_CDEMENU_MODULE_FALSE@CDEMENU_LTLIBS =
-module_flags = -export_dynamic -avoid-version -module -no-undefined
@@ -18,22 +9,3 @@
modulesdir = $(libdir)/gnome-vfs-2.0/modules
modules_LTLIBRARIES = \
- $(CDDA_LTLIBS) \
- libcomputer.la \
-- libextfs.la \
- libfile.la \
- libnetwork.la \
- libnntp.la \
-@@ -292,12 +291,6 @@
- libcomputer_la_SOURCES = computer-method.c
- libcomputer_la_LDFLAGS = $(module_flags)
- libcomputer_la_LIBADD = $(MODULES_FILE_LIBS) ../libgnomevfs/libgnomevfs-2.la
--
--
--### `extfs' method
--libextfs_la_SOURCES = extfs-method.c
--libextfs_la_LDFLAGS = $(module_flags)
--libextfs_la_LIBADD = $(MODULES_FILE_LIBS) ../libgnomevfs/libgnomevfs-2.la
-
-
- ### `file' method
diff --git a/devel/gnomevfs2/files/patch-gnome-vfs-2.0.pc.in b/devel/gnomevfs2/files/patch-gnome-vfs-2.0.pc.in
index c75f0d973243..4acd9a1bc552 100644
--- a/devel/gnomevfs2/files/patch-gnome-vfs-2.0.pc.in
+++ b/devel/gnomevfs2/files/patch-gnome-vfs-2.0.pc.in
@@ -1,12 +1,13 @@
$FreeBSD$
---- gnome-vfs-2.0.pc.in 2002/02/16 13:07:24 1.1
-+++ gnome-vfs-2.0.pc.in 2002/02/16 13:07:38
+--- gnome-vfs-2.0.pc.in.orig Thu Oct 28 13:25:35 2004
++++ gnome-vfs-2.0.pc.in Thu Oct 28 13:25:51 2004
@@ -8,5 +8,5 @@
Description: The GNOME virtual file-system libraries
Version: @VERSION@
- Requires: bonobo-activation-2.0,gthread-2.0,gmodule-2.0
+ Requires: bonobo-activation-2.0 libbonobo-2.0 gconf-2.0 gthread-2.0 gmodule-2.0
-Libs: -L${libdir} -lgnomevfs-2
+Libs: -L${libdir} -lgnomevfs-2 @PTHREAD_LIB@
Cflags: -I${includedir}/gnome-vfs-2.0 -I${libdir}/gnome-vfs-2.0/include
+
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_eggdirfuncs.c b/devel/gnomevfs2/files/patch-libgnomevfs_eggdirfuncs.c
new file mode 100644
index 000000000000..82e0e5f61891
--- /dev/null
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_eggdirfuncs.c
@@ -0,0 +1,11 @@
+--- libgnomevfs/eggdirfuncs.c.orig Sat Jul 24 03:08:10 2004
++++ libgnomevfs/eggdirfuncs.c Sat Jul 24 03:08:50 2004
+@@ -106,7 +106,7 @@
+ data_dirs = (gchar *) g_getenv ("XDG_DATA_DIRS");
+
+ if (!data_dirs || !data_dirs[0])
+- data_dirs = "/usr/local/share/:/usr/share/";
++ data_dirs = "/usr/local/share/:%%X11BASE%%/share/:/usr/share/:/usr/local/share/gnome/:%%X11BASE%%/share/gnome/:/usr/share/gnome/";
+
+ data_dir_vector = g_strsplit (data_dirs, ":", 0);
+
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-mime-info.c b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-mime-info.c
new file mode 100644
index 000000000000..a61e83417651
--- /dev/null
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-mime-info.c
@@ -0,0 +1,11 @@
+--- libgnomevfs/gnome-vfs-mime-info.c.orig Wed Aug 4 13:41:52 2004
++++ libgnomevfs/gnome-vfs-mime-info.c Wed Aug 4 13:42:10 2004
+@@ -149,7 +149,7 @@
+
+ xdg_data_dirs = g_getenv ("XDG_DATA_DIRS");
+ if (!xdg_data_dirs) {
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
+ }
+
+ split_data_dirs = g_strsplit (xdg_data_dirs, ":", 0);
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-resolve.c b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-resolve.c
new file mode 100644
index 000000000000..c58be91fa94b
--- /dev/null
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-resolve.c
@@ -0,0 +1,13 @@
+--- libgnomevfs/gnome-vfs-resolve.c.orig Sat Jul 31 17:52:23 2004
++++ libgnomevfs/gnome-vfs-resolve.c Sat Jul 31 17:52:45 2004
+@@ -171,8 +171,10 @@
+ switch (error) {
+
+ case EAI_NONAME: return GNOME_VFS_ERROR_HOST_NOT_FOUND;
++#if defined(EAI_ADDRFAMILY) && defined(EAI_NODATA)
+ case EAI_ADDRFAMILY:
+ case EAI_NODATA: return GNOME_VFS_ERROR_HOST_HAS_NO_ADDRESS;
++#endif
+ case EAI_SYSTEM: return gnome_vfs_result_from_errno ();
+ case EAI_FAIL:
+ case EAI_AGAIN: return GNOME_VFS_ERROR_NAMESERVER;
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c
index 7028e5a91b8e..5d37cc768ddb 100644
--- a/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c
@@ -1,35 +1,10 @@
---- libgnomevfs/gnome-vfs-unix-mounts.c.orig Mon Feb 16 06:13:27 2004
-+++ libgnomevfs/gnome-vfs-unix-mounts.c Sat Apr 17 00:45:01 2004
-@@ -141,9 +141,9 @@
- FD_ZERO(&read_fds);
- FD_SET(pipes[0], &read_fds);
-
-- /* Wait max half a second */
-- tv.tv_sec = 0;
-- tv.tv_usec = 500;
-+ /* Wait max one second */
-+ tv.tv_sec = 1;
-+ tv.tv_usec = 0;
-
- res = select(pipes[0] + 1,
- &read_fds, NULL, NULL, &tv);
-@@ -428,7 +428,7 @@
- mount_entry->mount_path = g_strdup (mntent[i].f_mntonname);
- mount_entry->device_path = g_strdup (mntent[i].f_mntfromname);
- mount_entry->filesystem_type = g_strdup (mntent[i].f_fstypename);
-- if (mntent[i].f_flags == MNT_RDONLY) {
-+ if (mntent[i].f_flags & MNT_RDONLY) {
- mount_entry->is_read_only = TRUE;
- }
-
-@@ -857,8 +857,9 @@
-
- #ifdef HAVE_SYS_SYSCTL_H
- if (usermnt != 0) {
-+ uid_t uid = getuid ();
- if (stat (fstab->fs_file, &sb) == 0) {
-- if (sb.st_uid != 0) {
-+ if (uid == 0 || sb.st_uid == uid) {
- mount_entry->is_user_mountable = TRUE;
- }
- }
+--- libgnomevfs/gnome-vfs-unix-mounts.c.orig Sun Sep 5 02:34:30 2004
++++ libgnomevfs/gnome-vfs-unix-mounts.c Sun Sep 5 02:35:08 2004
+@@ -43,6 +43,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <signal.h>
++#include <poll.h>
+ #include <libgnomevfs/gnome-vfs.h>
+
+ #include "gnome-vfs-unix-mounts.h"
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-utils.c b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-utils.c
index a168c6acdac8..9788a89f060e 100644
--- a/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-utils.c
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_gnome-vfs-utils.c
@@ -1,25 +1,6 @@
---- libgnomevfs/gnome-vfs-utils.c.orig Fri Apr 16 06:43:05 2004
-+++ libgnomevfs/gnome-vfs-utils.c Mon Apr 19 15:41:47 2004
-@@ -797,7 +797,9 @@
-
- #if HAVE_STATVFS
- statfs_result = statvfs (unescaped_path, &statfs_buffer);
-+#define statfs_bsize f_frsize
- #else
-+#define statfs_bsize f_bsize
- #if STATFS_ARGS == 2
- statfs_result = statfs (unescaped_path, &statfs_buffer);
- #elif STATFS_ARGS == 4
-@@ -838,7 +840,7 @@
- }
- #endif
-
-- block_size = statfs_buffer.f_bsize;
-+ block_size = statfs_buffer.statfs_bsize;
- free_blocks = statfs_buffer.f_bavail;
-
- *size = block_size * free_blocks;
-@@ -866,7 +868,7 @@
+--- libgnomevfs/gnome-vfs-utils.c.orig Mon Aug 16 11:11:09 2004
++++ libgnomevfs/gnome-vfs-utils.c Mon Aug 16 11:11:16 2004
+@@ -871,7 +871,7 @@
paths = g_strsplit (gnome_var, ":", 0);
for (temp_paths = paths; *temp_paths != NULL; temp_paths++) {
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c b/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c
index 0c6c3d28ad0a..472a4b5f6c19 100644
--- a/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c
@@ -1,11 +1,11 @@
---- libgnomevfs/xdgmime.c.orig Wed Jun 23 20:15:25 2004
-+++ libgnomevfs/xdgmime.c Wed Jun 23 20:15:41 2004
-@@ -97,7 +97,7 @@
+--- libgnomevfs/xdgmime.c.orig Thu Jul 22 11:20:13 2004
++++ libgnomevfs/xdgmime.c Thu Jul 22 11:20:52 2004
+@@ -189,7 +189,7 @@
- xdg_data_dirs = getenv ("XDG_DATA_DIRS");
- if (xdg_data_dirs == NULL)
-- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
+ xdg_data_dirs = getenv ("XDG_DATA_DIRS");
+ if (xdg_data_dirs == NULL)
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
- ptr = xdg_data_dirs;
+ ptr = xdg_data_dirs;
diff --git a/devel/gnomevfs2/files/patch-modules_default-modules.conf b/devel/gnomevfs2/files/patch-modules_default-modules.conf
deleted file mode 100644
index 0efb87aa888c..000000000000
--- a/devel/gnomevfs2/files/patch-modules_default-modules.conf
+++ /dev/null
@@ -1,12 +0,0 @@
---- modules/default-modules.conf.orig Thu Aug 26 21:01:12 2004
-+++ modules/default-modules.conf Thu Aug 26 21:01:22 2004
-@@ -38,9 +38,6 @@
-
- ssh: ssh
-
--# The various access methods implemented by the extfs system.
--a ar arj cpio deb hp48 lha mailfs patchfs rar rpm rpms trpm zip zoo: extfs
--
- # vfolder desktop method
- applications: vfolder-desktop
- applications-all-users: vfolder-desktop
diff --git a/devel/gnomevfs2/files/patch-modules_extfs-method.c b/devel/gnomevfs2/files/patch-modules_extfs-method.c
deleted file mode 100644
index 129e9c4e131e..000000000000
--- a/devel/gnomevfs2/files/patch-modules_extfs-method.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/extfs-method.c.orig Thu Aug 12 20:04:05 2004
-+++ modules/extfs-method.c Thu Aug 12 20:06:20 2004
-@@ -61,7 +61,7 @@
-
-
- static ssize_t
--getdelim (char **lineptr, size_t n, int terminator, FILE *stream)
-+getdelim (char **lineptr, size_t *n, int terminator, FILE *stream)
- {
- char *line, *p;
- size_t size, copy;
diff --git a/devel/gnomevfs2/pkg-plist b/devel/gnomevfs2/pkg-plist
index 3f5cc01a3a79..7bec57259d84 100644
--- a/devel/gnomevfs2/pkg-plist
+++ b/devel/gnomevfs2/pkg-plist
@@ -3,21 +3,11 @@ bin/gnomevfs-copy
bin/gnomevfs-info
bin/gnomevfs-ls
bin/gnomevfs-mkdir
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_default_applications.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_default_applications.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_default_applications.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_url_handlers.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_url_handlers.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_url_handlers.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/system_http_proxy.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/system_http_proxy.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/system_http_proxy.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/system_smb.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/system_smb.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/system_smb.schemas > /dev/null || /usr/bin/true
+bin/gnomevfs-rm
%%CDPARANOIA%%etc/gnome-vfs-2.0/modules/cdda-module.conf
etc/gnome-vfs-2.0/modules/default-modules.conf
%%SAMBA%%etc/gnome-vfs-2.0/modules/smb-module.conf
+etc/gnome-vfs-2.0/modules/ssl-modules.conf
etc/gnome-vfs-2.0/vfolders/applications-all-users.vfolder-info
etc/gnome-vfs-2.0/vfolders/favorites.vfolder-info
etc/gnome-vfs-2.0/vfolders/network.vfolder-info
@@ -26,11 +16,13 @@ etc/gnome-vfs-2.0/vfolders/server-settings.vfolder-info
etc/gnome-vfs-2.0/vfolders/start-here.vfolder-info
etc/gnome-vfs-2.0/vfolders/system-settings.vfolder-info
include/gnome-vfs-2.0/include/gnome-vfs-file-size.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-address.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-application-registry.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-async-ops.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-cancellation.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-context.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-directory.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-dns-sd.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-drive.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-enum-types.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-file-info.h
@@ -40,11 +32,13 @@ include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-handle.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-init.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-job-limit.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-handlers.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-info-cache.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-monitor.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-utils.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-module-callback.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-monitor.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-ops.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-resolve.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-result.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-standard-callbacks.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-types.h
@@ -71,6 +65,7 @@ lib/bonobo/monikers/libmoniker_gnome_vfs_std.so
lib/gnome-vfs-2.0/modules/libbzip2.so
%%CDPARANOIA%%lib/gnome-vfs-2.0/modules/libcdda.so
lib/gnome-vfs-2.0/modules/libcomputer.so
+lib/gnome-vfs-2.0/modules/libdns-sd.so
lib/gnome-vfs-2.0/modules/libfile.so
lib/gnome-vfs-2.0/modules/libftp.so
lib/gnome-vfs-2.0/modules/libgzip.so
@@ -79,7 +74,6 @@ lib/gnome-vfs-2.0/modules/libnetwork.so
lib/gnome-vfs-2.0/modules/libnntp.so
lib/gnome-vfs-2.0/modules/libsftp.so
%%SAMBA%%lib/gnome-vfs-2.0/modules/libsmb.so
-lib/gnome-vfs-2.0/modules/libssh.so
lib/gnome-vfs-2.0/modules/libtar.so
lib/gnome-vfs-2.0/modules/libvfolder-desktop.so
lib/gnome-vfs-2.0/modules/libvfs-pipe.so
@@ -87,12 +81,71 @@ lib/gnome-vfs-2.0/modules/libvfs-test.so
lib/gnome-vfs-2.0/modules/libvfs-translate.so
lib/libgnomevfs-2.a
lib/libgnomevfs-2.so
-lib/libgnomevfs-2.so.600
+lib/libgnomevfs-2.so.800
libdata/bonobo/servers/GNOME_VFS_Daemon.server
libdata/bonobo/servers/GNOME_VFS_Moniker_std.server
libdata/pkgconfig/gnome-vfs-2.0.pc
libdata/pkgconfig/gnome-vfs-module-2.0.pc
libexec/gnome-vfs-daemon
+share/doc/gnome-vfs-2.0/about.html
+share/doc/gnome-vfs-2.0/advanced-operations.html
+share/doc/gnome-vfs-2.0/data-types.html
+share/doc/gnome-vfs-2.0/gnome-vfs-2.0.devhelp
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-application-registry.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-async-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-cancellation.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-context.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-basic-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-find-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-list-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-dns-sd.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-drive.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-advanced-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-basic-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-info-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-info.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-rw-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-size.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-trunc-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-inet-connection.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-init.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-method.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-database.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-monitor.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-callback-module-api.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-callback.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-shared.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-monitor.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-parse-ls.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-resolve.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-result.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-socket-buffer.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-socket.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-ssl.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-standard-callbacks.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-transform.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-uri.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-utils.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-volume-monitor.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-volume.html
+share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-xfer.html
+share/doc/gnome-vfs-2.0/gnome-vfs-directory-operations.html
+share/doc/gnome-vfs-2.0/gnome-vfs-file-and-dirs-ops.html
+share/doc/gnome-vfs-2.0/gnome-vfs-first-steps.html
+share/doc/gnome-vfs-2.0/gnome-vfs-writing-modules.html
+share/doc/gnome-vfs-2.0/home.png
+share/doc/gnome-vfs-2.0/index.html
+share/doc/gnome-vfs-2.0/index.sgml
+share/doc/gnome-vfs-2.0/left.png
+share/doc/gnome-vfs-2.0/mime-registry.html
+share/doc/gnome-vfs-2.0/modules.html
+share/doc/gnome-vfs-2.0/networking.html
+share/doc/gnome-vfs-2.0/right.png
+share/doc/gnome-vfs-2.0/style.css
+share/doc/gnome-vfs-2.0/up.png
+share/doc/gnome-vfs-2.0/volumes.html
@exec mkdir -p %D/share/gnome/vfolders
%%KDEMENUS%%share/gnome/vfolders/KDE.directory
share/locale/af/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -138,6 +191,7 @@ share/locale/ml/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/mn/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/mr/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ms/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/nb/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ne/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/nl/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/nn/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -165,6 +219,7 @@ share/locale/yi/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/zh_CN/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/zh_TW/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrm share/gnome/vfolders
+@dirrm share/doc/gnome-vfs-2.0
@dirrm include/gnome-vfs-module-2.0/libgnomevfs
@dirrm include/gnome-vfs-module-2.0
@dirrm include/gnome-vfs-2.0/libgnomevfs