aboutsummaryrefslogtreecommitdiff
path: root/devel/gnustep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnustep/Makefile')
-rw-r--r--devel/gnustep/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/gnustep/Makefile b/devel/gnustep/Makefile
index 4421a6be45da..f1abb996ff78 100644
--- a/devel/gnustep/Makefile
+++ b/devel/gnustep/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: gnustep
-# Version required: 0.6.0
+# Version required: 0.6.5
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= gstep-core-0.6.0
-PKGNAME= gnustep-0.6.0
+DISTNAME= gstep-core-0.6.5
+PKGNAME= gnustep-0.6.5
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/ \
ftp://ftp.peanuts.org/Mirrors/GNUstep/gnustep/core/
@@ -25,13 +25,15 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
+WRKSRC= ${WRKDIR}/gstep-0.6.5
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
- --with-tiff-include=${LOCALBASE}/include
+ --with-tiff-include=${LOCALBASE}/include \
+ --enable-threads=posix
USE_GMAKE= yes
USE_XLIB= yes
MAKEFILE=