aboutsummaryrefslogtreecommitdiff
path: root/devel/go-runewidth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/go-runewidth/Makefile')
-rw-r--r--devel/go-runewidth/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/go-runewidth/Makefile b/devel/go-runewidth/Makefile
new file mode 100644
index 000000000000..42fd950c5e70
--- /dev/null
+++ b/devel/go-runewidth/Makefile
@@ -0,0 +1,25 @@
+# Created by: Akinori MUSHA aka knu <knu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= runewidth
+PORTVERSION= 0.0.0.20140623
+CATEGORIES= devel
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Go library to get the fixed width of a character or string
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= mattn
+GH_PROJECT= ${PKGNAMEPREFIX}${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= d70c973
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>