aboutsummaryrefslogtreecommitdiff
path: root/devel/gsettings-desktop-schemas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gsettings-desktop-schemas/Makefile')
-rw-r--r--devel/gsettings-desktop-schemas/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/devel/gsettings-desktop-schemas/Makefile b/devel/gsettings-desktop-schemas/Makefile
index e284960c2c0f..18d11614b864 100644
--- a/devel/gsettings-desktop-schemas/Makefile
+++ b/devel/gsettings-desktop-schemas/Makefile
@@ -1,9 +1,9 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/devel/gsettings-desktop-schemas/Makefile,v 1.13 2011/04/27 21:18:30 kwm Exp $
+# $MCom: ports/trunk/devel/gsettings-desktop-schemas/Makefile 18610 2013-06-30 16:33:05Z marcus $
PORTNAME= gsettings-desktop-schemas
-PORTVERSION= 3.0.1
+PORTVERSION= 3.6.1
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,15 +11,14 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Collection of globally shared GSetting schemas
-RUN_DEPENDS= ${LOCALBASE}/etc/fonts/conf.avail/31-cantarell.conf:${PORTSDIR}/x11-fonts/cantarell-fonts
-
LICENSE= LGPL21
-USES= pkgconfig gettext
-USE_BZIP2= yes
-USE_GMAKE= yes
+RUN_DEPENDS= ${LOCALBASE}/etc/fonts/conf.avail/31-cantarell.conf:${PORTSDIR}/x11-fonts/cantarell-fonts
+
+USE_XZ= yes
+USES= gettext gmake pathfix pkgconfig
USE_PERL5_BUILD= yes
-USE_GNOME= gnomehack intltool glib20
+USE_GNOME= intltool glib20 introspection:build
GNU_CONFIGURE= yes
GLIB_SCHEMAS= org.gnome.desktop.a11y.applications.gschema.xml \
@@ -29,6 +28,7 @@ GLIB_SCHEMAS= org.gnome.desktop.a11y.applications.gschema.xml \
org.gnome.desktop.background.gschema.xml \
org.gnome.desktop.default-applications.gschema.xml \
org.gnome.desktop.enums.xml \
+ org.gnome.desktop.input-sources.gschema.xml \
org.gnome.desktop.interface.gschema.xml \
org.gnome.desktop.lockdown.gschema.xml \
org.gnome.desktop.media-handling.gschema.xml \
@@ -37,6 +37,9 @@ GLIB_SCHEMAS= org.gnome.desktop.a11y.applications.gschema.xml \
org.gnome.desktop.sound.gschema.xml \
org.gnome.desktop.thumbnailers.gschema.xml \
org.gnome.desktop.thumbnail-cache.gschema.xml \
+ org.gnome.desktop.wm.keybindings.gschema.xml \
+ org.gnome.desktop.wm.preferences.gschema.xml \
+ org.gnome.system.locale.gschema.xml \
org.gnome.system.proxy.gschema.xml
.include <bsd.port.mk>