aboutsummaryrefslogtreecommitdiff
path: root/devel/guikachu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/guikachu/Makefile')
-rw-r--r--devel/guikachu/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/guikachu/Makefile b/devel/guikachu/Makefile
new file mode 100644
index 000000000000..1db15045dd69
--- /dev/null
+++ b/devel/guikachu/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: guikachu
+# Date created: 7 Nov 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= guikachu
+PORTVERSION= 1.5.4pre2
+CATEGORIES= devel palm gnome
+MASTER_SITES= http://cactus.rulez.org/projects/guikachu/download/
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= Resource editor for PalmOS(tm) systems
+
+LIB_DEPENDS= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26 \
+ gnomevfsmm-2.6.1:${PORTSDIR}/devel/gnome-vfsmm
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GCC= 3.4
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/mime_packagedir/s|(mimedir)|(prefix)/share/mime|' \
+ -e '/(UPDATE_MIME)/s|(mimedir)|(prefix)/share/mime|' \
+ ${WRKSRC}/data/Makefile.in
+
+.include <bsd.port.mk>