aboutsummaryrefslogtreecommitdiff
path: root/devel/gwenhywfar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gwenhywfar/Makefile')
-rw-r--r--devel/gwenhywfar/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index 9454379f8550..73a8f6884dc1 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -55,11 +55,13 @@ CONFIGURE_ARGS+=--with-fox-includes=${LOCALBASE}/include/fox-1.6 \
. elif ${SLAVEPORT}=="gtk2"
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
+USES+= gnome
USE_GNOME+= cairo gdkpixbuf2 gtk20
. elif ${SLAVEPORT}=="gtk3"
+USES+= gnome
USE_GNOME+= cairo gdkpixbuf2 gtk30
. elif ${SLAVEPORT}=="qt5"
-USES+= compiler:c++11-lang qmake:no_env qt:5
+USES+= compiler:c++11-lang gl qmake:no_env qt:5
USE_GL= gl
USE_QT= core gui widgets \
buildtools_build qmake_build