aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-BNFC/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-BNFC/Makefile')
-rw-r--r--devel/hs-BNFC/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/hs-BNFC/Makefile b/devel/hs-BNFC/Makefile
index 3bd6fe2a9cf8..bb4b478d0c2d 100644
--- a/devel/hs-BNFC/Makefile
+++ b/devel/hs-BNFC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bnfc
PORTVERSION= 2.3b
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cs.chalmers.se/~markus/BNFC/ \
http://www.cs.chalmers.se/Cs/Grundutb/Kurser/komp/current/resources/
@@ -20,18 +21,17 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
do-install:
- ${INSTALL_DATA} ${WRKSRC}/bnfc ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bnfc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
post-install:
+ ${RM} -f ${WRKSRC}/examples/.cvsignore
${RM} -f ${WRKSRC}/examples/haskell-core/.cvsignore
${MKDIR} ${EXAMPLESDIR}
- ${CP} -pR ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/LBNF-report.tex ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>