aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-BNFC
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-BNFC')
-rw-r--r--devel/hs-BNFC/Makefile7
-rw-r--r--devel/hs-BNFC/distinfo4
-rw-r--r--devel/hs-BNFC/files/patch-Main.hs13
-rw-r--r--devel/hs-BNFC/files/patch-MultiView.hs11
-rw-r--r--devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs15
-rw-r--r--devel/hs-BNFC/files/patch-formats__c__CTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs29
-rw-r--r--devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs31
-rw-r--r--devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs20
-rw-r--r--devel/hs-BNFC/files/patch-formats__java__JavaTop.hs20
-rw-r--r--devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs11
-rw-r--r--devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs22
15 files changed, 4 insertions, 235 deletions
diff --git a/devel/hs-BNFC/Makefile b/devel/hs-BNFC/Makefile
index df1391005da2..ca61bc86414e 100644
--- a/devel/hs-BNFC/Makefile
+++ b/devel/hs-BNFC/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= BNFC
-PORTVERSION= 2.4.2.0
-PORTREVISION= 3
+PORTVERSION= 2.4.2.1
CATEGORIES= devel haskell
-MAINTAINER= kaiw27@gmail.com
+MAINTAINER= haskell@FreeBSD.org
COMMENT= A Labelled BNF converter
LICENSE= GPLv2
@@ -21,7 +20,5 @@ USE_CABAL= mtl
STANDALONE= yes
EXECUTABLE= bnfc
-HASKELL98= yes
-
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-BNFC/distinfo b/devel/hs-BNFC/distinfo
index 5a5afee487fa..a29b0e0fafdb 100644
--- a/devel/hs-BNFC/distinfo
+++ b/devel/hs-BNFC/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/BNFC-2.4.2.0.tar.gz) = c0c69b50f17e13cf5afd9c9d8ce2cabab1273c14bebc91f4f065068af5a7ca5a
-SIZE (cabal/BNFC-2.4.2.0.tar.gz) = 182328
+SHA256 (cabal/BNFC-2.4.2.1.tar.gz) = 24d0964a28c475a722fab4f332407f33c652e11233fe76287e62f6896b62d128
+SIZE (cabal/BNFC-2.4.2.1.tar.gz) = 3546017
diff --git a/devel/hs-BNFC/files/patch-Main.hs b/devel/hs-BNFC/files/patch-Main.hs
deleted file mode 100644
index cf13337bafea..000000000000
--- a/devel/hs-BNFC/files/patch-Main.hs
+++ /dev/null
@@ -1,13 +0,0 @@
---- Main.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ Main.hs 2012-05-13 12:32:42.198463500 +0200
-@@ -41,8 +41,9 @@
-
- import MultiView (preprocessMCF, mkTestMulti, mkMakefileMulti)
-
--import System
- import System.Exit
-+import System.Environment
-+import System.Process
- import Char
- import Data.List (elemIndex)
-
diff --git a/devel/hs-BNFC/files/patch-MultiView.hs b/devel/hs-BNFC/files/patch-MultiView.hs
deleted file mode 100644
index 75b3553e4268..000000000000
--- a/devel/hs-BNFC/files/patch-MultiView.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./MultiView.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./MultiView.hs 2012-05-12 22:16:41.000000000 +0200
-@@ -109,7 +109,7 @@
- ["import qualified Print" ++ cnc | cnc <- cncs] ++
- ["import Abs" ++ abs,
- "import ErrM",
-- "import System (getArgs)",
-+ "import System.Environment (getArgs)",
- "",
- "main :: IO ()",
- "main = do",
diff --git a/devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs b/devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs
deleted file mode 100644
index f2b9c8a8a692..000000000000
--- a/devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./formats/c-sharp/CSharpTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/c-sharp/CSharpTop.hs 2012-05-13 12:13:16.373594632 +0200
-@@ -48,10 +48,10 @@
- import CFtoCSharpPrinter
- import CFtoLatex
- import CSharpUtils
--import System
- import GetCF
- import Char
--import System
-+import System.Exit
-+import System.Environment
- import System.Directory
- import System.IO
- import System.Process
diff --git a/devel/hs-BNFC/files/patch-formats__c__CTop.hs b/devel/hs-BNFC/files/patch-formats__c__CTop.hs
deleted file mode 100644
index f982833d911b..000000000000
--- a/devel/hs-BNFC/files/patch-formats__c__CTop.hs
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./formats/c/CTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/c/CTop.hs 2012-05-13 12:06:24.160466196 +0200
-@@ -26,10 +26,9 @@
- import CFtoCSkel
- import CFtoCPrinter
- import CFtoLatex
---- import System
- import GetCF
- import Char
--import System
-+import System.Exit
-
- makeC :: Bool -> String -> FilePath -> IO ()
- makeC make name file = do
diff --git a/devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs b/devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs
deleted file mode 100644
index 9dc51c894329..000000000000
--- a/devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./formats/cpp/CPPTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/cpp/CPPTop.hs 2012-05-13 12:14:55.788469382 +0200
-@@ -27,10 +27,9 @@
- import CFtoCVisitSkel
- import CFtoCPPPrinter
- import CFtoLatex
--import System
- import GetCF
- import Char
--import System
-+import System.Exit
-
- makeCPP :: Bool -> String -> FilePath -> IO ()
- makeCPP make name file = do
diff --git a/devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs b/devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs
deleted file mode 100644
index a8f030e9385b..000000000000
--- a/devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./formats/cpp_stl/STLTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/cpp_stl/STLTop.hs 2012-05-13 12:10:03.269465642 +0200
-@@ -29,10 +29,9 @@
- import CFtoCVisitSkelSTL
- import CFtoSTLPrinter
- import CFtoLatex
--import System
- import GetCF
- import Char
--import System
-+import System.Exit
- import STLUtils
-
- makeSTL :: Bool -> Bool -> Maybe String -> String -> FilePath -> IO ()
diff --git a/devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs b/devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs
deleted file mode 100644
index f9bbbea1fb25..000000000000
--- a/devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./formats/f-sharp/FSharpTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/f-sharp/FSharpTop.hs 2012-05-12 23:50:50.000000000 +0200
-@@ -35,10 +35,9 @@
- import CFtoXML
- import GetCF
- import Utils
--
-+import System.Exit
- import Char
- import Data.Maybe (fromMaybe,maybe)
--import System
- import Monad(when)
-
- -- naming conventions
diff --git a/devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs b/devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs
deleted file mode 100644
index 44716c8c428c..000000000000
--- a/devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./formats/haskell-gadt/HaskellTopGADT.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/haskell-gadt/HaskellTopGADT.hs 2012-05-13 12:27:10.838459849 +0200
-@@ -42,7 +42,7 @@
-
- import Char
- import Data.Maybe (fromMaybe,maybe)
--import System
-+import System.Exit
- import Monad(when)
-
- -- naming conventions
-@@ -231,7 +231,7 @@
- ["-- automatically generated by BNF Converter",
- "module Main where\n",
- "",
-- "import IO ( stdin, hGetContents )",
-+ "import System.IO.Error ( stdin, hGetContents )",
- "import System ( getArgs, getProgName )",
- "",
- "import " ++ alexFileM opts,
-@@ -242,7 +242,7 @@
- if lay then ("import " ++ layoutFileM opts) else "",
- if use_xml then ("import " ++ xmlFileM opts) else "",
- if_glr "import Data.FiniteMap(FiniteMap, lookupFM, fmToList)",
-- if_glr "import Maybe(fromJust)",
-+ if_glr "import Data.Maybe(fromJust)",
- "import " ++ errFileM opts,
- "",
- if use_glr
diff --git a/devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs b/devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs
deleted file mode 100644
index 612fdf92a196..000000000000
--- a/devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs
+++ /dev/null
@@ -1,31 +0,0 @@
---- ./formats/haskell2/HaskellTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/haskell2/HaskellTop.hs 2012-05-13 12:29:09.892465893 +0200
-@@ -42,7 +42,7 @@
-
- import Char
- import Data.Maybe (fromMaybe,maybe)
--import System
-+import System.Exit
- import Monad(when)
-
- -- naming conventions
-@@ -235,8 +235,8 @@
- ["-- automatically generated by BNF Converter",
- "module Main where\n",
- "",
-- "import IO ( stdin, hGetContents )",
-- "import System ( getArgs, getProgName )",
-+ "import System.IO ( stdin, hGetContents )",
-+ "import System.Environment ( getArgs, getProgName )",
- "",
- "import " ++ alexFileM opts,
- "import " ++ happyFileM opts,
-@@ -246,7 +246,7 @@
- if lay then ("import " ++ layoutFileM opts) else "",
- if use_xml then ("import " ++ xmlFileM opts) else "",
- if_glr "import Data.FiniteMap(FiniteMap, lookupFM, fmToList)",
-- if_glr "import Maybe(fromJust)",
-+ if_glr "import Data.Maybe(fromJust)",
- "import " ++ errFileM opts,
- "",
- if use_glr
diff --git a/devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs b/devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs
deleted file mode 100644
index 9876a272e7ae..000000000000
--- a/devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./formats/java1.5/JavaTop15.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/java1.5/JavaTop15.hs 2012-05-13 12:20:30.194507156 +0200
-@@ -39,7 +39,7 @@
- -- Dependencies.
- -------------------------------------------------------------------
- import Directory ( createDirectory )
--import IO ( try, isAlreadyExistsError )
-+import System.IO.Error ( try, isAlreadyExistsError )
-
- import Utils
- import CF
-@@ -54,7 +54,7 @@
- import CFtoFoldVisitor
- import CFtoAllVisitor
- import CFtoLatex
--import System
-+import System.Exit
- import GetCF ( tryReadCF, writeFileRep )
- import Char
- import List(intersperse)
diff --git a/devel/hs-BNFC/files/patch-formats__java__JavaTop.hs b/devel/hs-BNFC/files/patch-formats__java__JavaTop.hs
deleted file mode 100644
index 7bcf7de66d57..000000000000
--- a/devel/hs-BNFC/files/patch-formats__java__JavaTop.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./formats/java/JavaTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/java/JavaTop.hs 2012-05-13 12:22:38.512466534 +0200
-@@ -38,7 +38,7 @@
- -- Dependencies.
- -------------------------------------------------------------------
- import Directory ( createDirectory )
--import IO ( try, isAlreadyExistsError )
-+import System.IO.Error ( try, isAlreadyExistsError )
-
- import Utils
- import CF
-@@ -49,7 +49,7 @@
- import CFtoJavaSkeleton
- import CFtoVisitSkel
- import CFtoLatex
--import System
-+import System.Exit
- import GetCF ( tryReadCF, writeFileRep )
- import Char
- import List(intersperse)
diff --git a/devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs b/devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs
deleted file mode 100644
index bfa4c9c7adaa..000000000000
--- a/devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./formats/ocaml/OCamlTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/ocaml/OCamlTop.hs 2012-05-13 12:04:23.291467169 +0200
-@@ -37,7 +37,7 @@
-
- import Char
- import Data.Maybe (fromMaybe,maybe)
--import System
-+import System.Exit
- import Monad(when)
-
- -- naming conventions
diff --git a/devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs b/devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs
deleted file mode 100644
index 56003177cc93..000000000000
--- a/devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./formats/profile/ProfileTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
-+++ ./formats/profile/ProfileTop.hs 2012-05-13 12:25:17.510460618 +0200
-@@ -37,7 +37,7 @@
- import Utils
-
- import Char
--import System
-+import System.Exit
- import Monad(when)
-
- -- naming conventions
-@@ -184,8 +184,8 @@
- "",
- "import Trees",
- "import Profile",
-- "import IO ( stdin, hGetContents )",
-- "import System ( getArgs, getProgName )",
-+ "import System.IO ( stdin, hGetContents )",
-+ "import System.Environment ( getArgs, getProgName )",
- "",
- "import " ++ alexFileM inDir name,
- "import " ++ happyFileM inDir name,