aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-ansi-terminal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-ansi-terminal/Makefile')
-rw-r--r--devel/hs-ansi-terminal/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/hs-ansi-terminal/Makefile b/devel/hs-ansi-terminal/Makefile
new file mode 100644
index 000000000000..c9a6cf21e0ee
--- /dev/null
+++ b/devel/hs-ansi-terminal/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hs-ansi-terminal
+# Date created: May 21, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ansi-terminal
+PORTVERSION= 0.5.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Simple ANSI terminal support, with Windows compatibility
+
+OPTIONS= EXAMPLE "Build the example application" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_EXAMPLE)
+CONFIGURE_ARGS+= --flags="Example"
+EXECUTABLE= ansi-terminal-example
+PLIST_SUB+= MAYBE_EXAMPLE=""
+.else
+CONFIGURE_ARGS+= --flags="-Example"
+PLIST_SUB+= MAYBE_EXAMPLE="@comment "
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>