aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-c2hs
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-c2hs')
-rw-r--r--devel/hs-c2hs/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
index 73e598367ab7..6542a3e13a20 100644
--- a/devel/hs-c2hs/Makefile
+++ b/devel/hs-c2hs/Makefile
@@ -24,12 +24,15 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
GHC_VERSION= 6.6.1
# 'owned' by lang/ghc:
-CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
+CABALDIR= ${PREFIX}/${SUBDIR}
CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+SUBDIR= lib/ghc-${GHC_VERSION}/cabal
-PLIST_FILES= bin/c2hs
+PLIST_FILES= bin/c2hs ${SUBDIR}/${PORTNAME}/C2HS.hs
+PLIST_DIRS= ${SUBDIR}/${PORTNAME}
CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} \
+ --datadir=${CABALDIR}/${PORTNAME} \
--libsubdir='' --datasubdir=''
do-configure: