aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-cabal-install/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-cabal-install/Makefile')
-rw-r--r--devel/hs-cabal-install/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/devel/hs-cabal-install/Makefile b/devel/hs-cabal-install/Makefile
index bff7afcbd183..5985f4713173 100644
--- a/devel/hs-cabal-install/Makefile
+++ b/devel/hs-cabal-install/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: hs-cabal-install
-# Date created: 2010-08-17
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= cabal-install
PORTVERSION= 0.14.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -20,7 +15,15 @@ CABAL_SETUP= Setup.hs
USE_CABAL= network>=1 random>=1 HTTP>=4000.0.2 zlib>=0.4
STANDALONE= yes
-EXECUTABLE= cabal
+EXECUTABLE= cabal-install
+
+# Some magic to make `cabal` work with a custom toolchain
+SUB_FILES= cabal
+SUB_LIST= AR=${AR} CC=${CC} CPP=${CPP} LD=${CC} RANLIB=${RANLIB}
+
+post-install::
+ @${MV} ${PREFIX}/bin/cabal ${PREFIX}/bin/cabal-install
+ ${INSTALL_SCRIPT} ${WRKDIR}/cabal ${PREFIX}/bin
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>