aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-cabal-install/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-cabal-install/Makefile')
-rw-r--r--devel/hs-cabal-install/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/hs-cabal-install/Makefile b/devel/hs-cabal-install/Makefile
index dc800238a5aa..c01f30c79e9e 100644
--- a/devel/hs-cabal-install/Makefile
+++ b/devel/hs-cabal-install/Makefile
@@ -19,10 +19,9 @@ EXECUTABLE= cabal-install
SUB_FILES= cabal
SUB_LIST= AR=${AR} CC=${CC} CPP=${CPP} LD=${LD} RANLIB=${RANLIB}
-NO_STAGE= yes
post-install::
- @${MV} ${PREFIX}/bin/cabal ${PREFIX}/bin/cabal-install
- ${INSTALL_SCRIPT} ${WRKDIR}/cabal ${PREFIX}/bin
+ @${MV} ${STAGEDIR}${PREFIX}/bin/cabal ${STAGEDIR}${PREFIX}/bin/cabal-install
+ ${INSTALL_SCRIPT} ${WRKDIR}/cabal ${STAGEDIR}${PREFIX}/bin
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>