aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-haddock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-haddock/Makefile')
-rw-r--r--devel/hs-haddock/Makefile46
1 files changed, 34 insertions, 12 deletions
diff --git a/devel/hs-haddock/Makefile b/devel/hs-haddock/Makefile
index 55e9b0d735b3..f65f3035e217 100644
--- a/devel/hs-haddock/Makefile
+++ b/devel/hs-haddock/Makefile
@@ -5,29 +5,28 @@
# $FreeBSD$
PORTNAME= haddock
-PORTVERSION= 2.1.0
-PORTREVISION= 2
+PORTVERSION= 2.4.2
CATEGORIES= devel haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/haddock/${PORTVERSION}/
+MASTER_SITES= http://www.haskell.org/haddock/dist/ \
+ http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= A documentation tool for Haskell
.if !defined(SLAVE)
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-
-.if exists(${LOCALBASE}/lib/libreadline.so.6)
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
-.endif
-
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-ghc-paths>=0.1.0.5:${PORTSDIR}/devel/hs-ghc-paths
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-ghc-paths>=0.1.0.5:${PORTSDIR}/devel/hs-ghc-paths
+LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
.else
NO_PKG_REGISTER=
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//g}
-GHC_VERSION= 6.8.3
+GHC_VERSION= 6.10.4
HADDOCK_VERSION= ${PORTVERSION}
CABAL_CMD= runghc Setup.lhs
@@ -42,13 +41,36 @@ PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
HADDOCK_VERSION=${HADDOCK_VERSION} \
DOCSDIR_REL=${DOCSDIR_REL}
+.include <bsd.port.pre.mk>
+
+.if !defined(SLAVE)
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if ${PORT_HADDOCK} == 11
+ECHO_MSG= ${PRINTF} "%b"
+IGNORE+= \n\t The ${LOCALBASE}/bin/haddock executable was already installed\n
+IGNORE+= \t by the lang/ghc port, setting the option WITH_HADDOCK.\n
+IGNORE+= \t You have to reinstall this last one with the right option\n
+IGNORE+= \t WITHOUT_HADDOCK.\n\c
+.elif ${PORT_HADDOCK} == 01
+ECHO_MSG= ${PRINTF} "%b"
+IGNORE+= \n\t This port depends on the lang/ghc port, which will install\n
+IGNORE+= \t the ${LOCALBASE}/bin/haddock executable, for the WITH_HADDOCK\n
+IGNORE+= \t option was set in it. You have to set the WITHOUT_HADDOCK\n
+IGNORE+= \t options in lang/ghc before to install devel/hs-haddock.\n\c
+.endif
+.endif
+
.SILENT:
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/doc/configure.ac
+
do-configure:
cd ${WRKSRC} && ${CABAL_CMD} configure --ghc --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ${CABAL_CMD} build --ghc-option="-package process-1.0.0.1"
+ cd ${WRKSRC} && ${CABAL_CMD} build
.if !defined(SLAVE)
cd ${WRKSRC} && ${CABAL_CMD} register --gen-script
.endif
@@ -63,4 +85,4 @@ post-install:
.endif
@${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>