aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-chill/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/i386-rtems-chill/Makefile')
-rw-r--r--devel/i386-rtems-chill/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/devel/i386-rtems-chill/Makefile b/devel/i386-rtems-chill/Makefile
index f35c08b6564b..27a5e5219459 100644
--- a/devel/i386-rtems-chill/Makefile
+++ b/devel/i386-rtems-chill/Makefile
@@ -9,9 +9,13 @@ PORTNAME= chill
PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib gcc/releases/${CHILLNAME}
-DISTFILES= ${NEWLIBNAME}.tar.gz ${CHILLNAME}.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
+ ${MASTER_SITE_SOURCEWARE:S/$/:gcc/}
+MASTER_SITE_SUBDIR= newlib \
+ gcc/releases/${CHILLNAME}/:gcc
+DISTFILES= ${NEWLIBNAME}.tar.gz \
+ ${CHILLNAME}.tar.gz:gcc
+
PATCHFILES= ${CHILLNAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
@@ -26,7 +30,6 @@ NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-chill
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-FETCH_DEPENDS= /nonexistent:${PORTSDIR}/devel/rtems-gcc:extract
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc