aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-g77
diff options
context:
space:
mode:
Diffstat (limited to 'devel/i386-rtems-g77')
-rw-r--r--devel/i386-rtems-g77/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index 74c9592d2541..fca18246231f 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -56,14 +56,9 @@ CONFIGURE_SCRIPT?= ../${G77NAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-NO_CPU_FLAGS= true
-MAKE_FLAGS= LANGUAGES="f77"
-MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
-# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
-# by NO_CPU_FLAGS, and since they are added long before here we are
-# stuck with this hack.
-CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
-CXXFLAGS:= ${CXXFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
+WITHOUT_CPU_CFLAGS= true
+MAKE_FLAGS= LANGUAGES="f77"
+MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH}
pre-configure:
@(cd ${WRKDIR} ; \