aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-gdb
diff options
context:
space:
mode:
Diffstat (limited to 'devel/i386-rtems-gdb')
-rw-r--r--devel/i386-rtems-gdb/Makefile90
-rw-r--r--devel/i386-rtems-gdb/distinfo30
-rw-r--r--devel/i386-rtems-gdb/files/patch-aa24
-rw-r--r--devel/i386-rtems-gdb/files/patch-ac31
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::igen::gen-engine.c62
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::igen::lf.c51
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::ppc::gen-idecode.c58
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::ppc::gen-model.c11
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c51
-rw-r--r--devel/i386-rtems-gdb/pkg-descr10
-rw-r--r--devel/i386-rtems-gdb/pkg-plist1
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.arm-rtems3
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.i386-rtems1
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.i960-rtems3
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.m68k-rtems1
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.mips-rtems3
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.powerpc-rtems2
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.sh-rtems3
-rw-r--r--devel/i386-rtems-gdb/pkg-plist.sparc-rtems4
19 files changed, 6 insertions, 433 deletions
diff --git a/devel/i386-rtems-gdb/Makefile b/devel/i386-rtems-gdb/Makefile
index c9706a1aa46d..e920ec26833d 100644
--- a/devel/i386-rtems-gdb/Makefile
+++ b/devel/i386-rtems-gdb/Makefile
@@ -6,91 +6,13 @@
#
PORTNAME= gdb
-PORTVERSION= 5.2
-PORTREVISION= 11
-CATEGORIES= devel
-MASTER_SITES= http://www.rtems.com/ftp/pub/rtems/snapshots/c_tools/gdb-5.2-1/source/
-MAINTAINER= ade@FreeBSD.org
-COMMENT= FSF gdb-5.2 base-port for RTEMS development
+MAINTAINER= stas@FreeBSD.org
-PATCHFILES= ${GDBNAME}-rtems-base-20020612.diff \
- ${GDBNAME}-rtems-cg-20020612.diff \
- ${GDBNAME}-rtems-rdbg-20020612.diff
-PATCH_SITES= ftp://ftp.rtems.com/pub/rtems/snapshots/c_tools/source/ \
- http://rtems.thehousleys.net/
+TGTARCH= i386
+TGTABI= rtems
-.include <bsd.port.pre.mk>
+WITH_RTEMS_PATCHES= yes
-LCLTARGET?= i386-rtems
-
-.if ${ARCH} == sparc64 && ${LCLTARGET} == arm-rtems
-BROKEN= "Does not build on sparc64"
-.endif
-
-GDBNAME= gdb-5.2
-PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-
-BUILD_DEPENDS= ${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
- ${LCLTARGET}-ld:${PORTSDIR}/devel/${LCLTARGET}-binutils
-RUN_DEPENDS= ${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
- ${LCLTARGET}-ld:${PORTSDIR}/devel/${LCLTARGET}-binutils
-
-PKGNAMEPREFIX= ${LCLTARGET}-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-ALL_TARGET= all info
-
-CONFIGURE_TARGET?= --target=${LCLTARGET}
-CONFIGURE_ARGS?= --verbose
-CONFIGURE_WRKSRC?= ${WRKDIR}/build-${LCLTARGET}
-CONFIGURE_SCRIPT?= ../${GDBNAME}/configure
-
-PATCH_DIST_STRIP?= -p1
-
-# Need to patch a patch file
-.if ${LCLTARGET} == powerpc-rtems
-PATCHFILES+= powerpc-gdb-5.2-hw_sem.c.diff:THN \
- powerpc-gdb-5.2-hw_shm.c.diff:THN \
- powerpc-gdb-5.2-ppc-ppc-instructions.diff:THN \
- powerpc-gdb-5.2-gdb-remote-sds.c.diff:THN
-PATCH_SITES+= http://rtems.thehousleys.net/:THN
-.endif
-
-# Need to patch a patch file
-.if ${LCLTARGET} == i960-rtems
-PATCHFILES+= i960-gdb-5.2-sem-switch.c.diff:THN
-PATCH_SITES+= http://rtems.thehousleys.net/:THN
-.endif
-
-# Need to patch a patch file
-.if ${LCLTARGET} == arm-rtems
-PATCHFILES+= arm-gdb-gdb-5.2-gdb-arm-tdep.c.diff:THN
-PATCH_SITES+= http://rtems.thehousleys.net/:THN
-.endif
-
-.if ${LCLTARGET} == sparc-rtems
-.if ${OSVERSION} >= 502000
-CONFIGURE_ARGS+= --verbose --disable-sim
-PLIST_SUB+= SPARC_NOSIM='@comment '
-.else
-CONFIGURE_ARGS+= --verbose --enable-sim
-PLIST_SUB+= SPARC_NOSIM=''
-MAN1= ${LCLTARGET}-run.1
-.endif
-.endif
-
-MAN1+= ${LCLTARGET}-gdb.1
-
-pre-configure:
- @(cd ${WRKDIR} ; ${MKDIR} build-${LCLTARGET})
-
-do-build:
- @(cd ${WRKDIR}/build-${LCLTARGET} ; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-
-do-install:
- @(cd ${WRKDIR}/build-${LCLTARGET} && \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-
-.include <bsd.port.post.mk>
+MASTERDIR= ${.CURDIR}/../cross-gdb
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/i386-rtems-gdb/distinfo b/devel/i386-rtems-gdb/distinfo
deleted file mode 100644
index 4e6f00fa7801..000000000000
--- a/devel/i386-rtems-gdb/distinfo
+++ /dev/null
@@ -1,30 +0,0 @@
-MD5 (gdb-5.2.tar.gz) = afb7d18f72be812ef405f6b271a36e03
-SHA256 (gdb-5.2.tar.gz) = 02f0ebf439aa6a7b41c51f0784ba4aa881c32c9c253a287afacb1220b3e792d9
-SIZE (gdb-5.2.tar.gz) = 14695979
-MD5 (gdb-5.2-rtems-base-20020612.diff) = d328e2959b8c83add5e2a3ca60582b03
-SHA256 (gdb-5.2-rtems-base-20020612.diff) = d50a0e041e6d73d6cfc836fb2ee47fea77978ee12b1c642ca6e03cf97107931d
-SIZE (gdb-5.2-rtems-base-20020612.diff) = 1190287
-MD5 (gdb-5.2-rtems-cg-20020612.diff) = 44f82adae65e657458fde1280a6ac2c9
-SHA256 (gdb-5.2-rtems-cg-20020612.diff) = b10cf5baaacf7c2adac80d071a058bdb6d78370122363df14dea539d81ce8d0b
-SIZE (gdb-5.2-rtems-cg-20020612.diff) = 27133
-MD5 (gdb-5.2-rtems-rdbg-20020612.diff) = 1fffe3010d9e33186497238efa9c3060
-SHA256 (gdb-5.2-rtems-rdbg-20020612.diff) = 6a6f8c8e72e8b1a5272751107a57fc4fe95dca55454ca3d92623576c845232f4
-SIZE (gdb-5.2-rtems-rdbg-20020612.diff) = 317857
-MD5 (powerpc-gdb-5.2-hw_sem.c.diff) = 41ebe594fb37ae2528c8d0f11e190c13
-SHA256 (powerpc-gdb-5.2-hw_sem.c.diff) = e367008b959c1d944b101da8031c423ff6c10aded1832f182e6d721fb73c5630
-SIZE (powerpc-gdb-5.2-hw_sem.c.diff) = 250
-MD5 (powerpc-gdb-5.2-hw_shm.c.diff) = deaef8b33d8812d0348b1271f21a68a0
-SHA256 (powerpc-gdb-5.2-hw_shm.c.diff) = b2370181958ab2cd4345488aa87524cae52d6cb5210fd85403bca9d767449eb5
-SIZE (powerpc-gdb-5.2-hw_shm.c.diff) = 250
-MD5 (powerpc-gdb-5.2-ppc-ppc-instructions.diff) = f23d0f6d15d7502871d1d09714aae66e
-SHA256 (powerpc-gdb-5.2-ppc-ppc-instructions.diff) = 85f4f111f14e5928d510a1f9a0a15f84945aad0455f7079f1a8f554a84b0ff92
-SIZE (powerpc-gdb-5.2-ppc-ppc-instructions.diff) = 230
-MD5 (powerpc-gdb-5.2-gdb-remote-sds.c.diff) = 05d09d8e7dc03b96a37d2d34b66554bb
-SHA256 (powerpc-gdb-5.2-gdb-remote-sds.c.diff) = bf97955b6c90ae054983e51a21d014064b69ebc7efc7afbc8030868685737831
-SIZE (powerpc-gdb-5.2-gdb-remote-sds.c.diff) = 324
-MD5 (i960-gdb-5.2-sem-switch.c.diff) = 931cada099d0160add29eb671120e68b
-SHA256 (i960-gdb-5.2-sem-switch.c.diff) = 5b9cba0e2d69855d8ffdeebdb4ec0e7dc5dfd67ab655c19e56aa094720251343
-SIZE (i960-gdb-5.2-sem-switch.c.diff) = 279
-MD5 (arm-gdb-gdb-5.2-gdb-arm-tdep.c.diff) = 8ff29a62f7c57a4c70c0d3b280f9e86e
-SHA256 (arm-gdb-gdb-5.2-gdb-arm-tdep.c.diff) = 9d68bd884fdd0460b6add2d4a831e59b3ed3450ffea227423a369a676ffe1f57
-SIZE (arm-gdb-gdb-5.2-gdb-arm-tdep.c.diff) = 220
diff --git a/devel/i386-rtems-gdb/files/patch-aa b/devel/i386-rtems-gdb/files/patch-aa
deleted file mode 100644
index 1f84f62ff4c2..000000000000
--- a/devel/i386-rtems-gdb/files/patch-aa
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.in.orig Thu May 18 01:00:23 2000
-+++ Makefile.in Tue Aug 29 16:28:47 2000
-@@ -662,9 +662,7 @@
- install-autoconf \
- install-automake \
- install-bash \
-- install-bfd \
- install-bzip2 \
-- install-opcodes \
- install-binutils \
- install-bison \
- install-byacc \
-@@ -696,11 +694,9 @@
- install-itcl \
- install-ld \
- install-libgui \
-- install-libiberty \
- install-libtool \
- install-m4 \
- install-make \
-- install-mmalloc \
- install-patch \
- install-perl \
- install-prms \
diff --git a/devel/i386-rtems-gdb/files/patch-ac b/devel/i386-rtems-gdb/files/patch-ac
deleted file mode 100644
index 861b13292684..000000000000
--- a/devel/i386-rtems-gdb/files/patch-ac
+++ /dev/null
@@ -1,31 +0,0 @@
---- etc/Makefile.in.orig Sat Jan 26 16:35:45 2002
-+++ etc/Makefile.in Tue Oct 15 06:18:35 2002
-@@ -46,7 +46,7 @@
- #### Host, target, and site specific Makefile fragments come in here.
- ###
-
--INFOFILES = standards.info configure.info
-+INFOFILES =
- DVIFILES = standards.dvi configure.dvi
-
- all:
-@@ -68,19 +68,6 @@
- done
-
- install-info: info
-- $(SHELL) $(srcdir)/../mkinstalldirs $(infodir)
-- if test ! -f standards.info; then cd $(srcdir); fi; \
-- if test -f standards.info; then \
-- for i in standards.info*; do \
-- $(INSTALL_DATA) $$i $(infodir)/$$i; \
-- done; \
-- fi
-- if test ! -f configure.info; then cd $(srcdir); fi; \
-- if test -f configure.info; then \
-- for i in configure.info*; do \
-- $(INSTALL_DATA) $$i $(infodir)/$$i; \
-- done; \
-- fi
-
- dvi:
- for f in $(DVIFILES); do \
diff --git a/devel/i386-rtems-gdb/files/patch-sim::igen::gen-engine.c b/devel/i386-rtems-gdb/files/patch-sim::igen::gen-engine.c
deleted file mode 100644
index d61b1e8770e3..000000000000
--- a/devel/i386-rtems-gdb/files/patch-sim::igen::gen-engine.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- sim/igen/gen-engine.c.orig Fri Feb 20 19:21:21 2004
-+++ sim/igen/gen-engine.c Fri Feb 20 19:22:13 2004
-@@ -98,21 +98,21 @@
- if (!options.gen.smp)
- {
-
-- lf_putstr (file, "
--/* CASE 1: NO SMP (with or with out instruction cache).
--
--In this case, we can take advantage of the fact that the current
--instruction address (CIA) does not need to be read from / written to
--the CPU object after the execution of an instruction.
--
--Instead, CIA is only saved when the main loop exits. This occures
--when either sim_engine_halt or sim_engine_restart is called. Both of
--these functions save the current instruction address before halting /
--restarting the simulator.
--
--As a variation, there may also be support for an instruction cracking
--cache. */
--
-+ lf_putstr (file, "\
-+/* CASE 1: NO SMP (with or with out instruction cache).\
-+\
-+In this case, we can take advantage of the fact that the current\
-+instruction address (CIA) does not need to be read from / written to\
-+the CPU object after the execution of an instruction.\
-+\
-+Instead, CIA is only saved when the main loop exits. This occures\
-+when either sim_engine_halt or sim_engine_restart is called. Both of\
-+these functions save the current instruction address before halting /\
-+restarting the simulator.\
-+\
-+As a variation, there may also be support for an instruction cracking\
-+cache. */\
-+\
- ");
-
- lf_putstr (file, "\n");
-@@ -215,14 +215,14 @@
- if (options.gen.smp)
- {
-
-- lf_putstr (file, "
--/* CASE 2: SMP (With or without ICACHE)
--
--The complexity here comes from needing to correctly halt the simulator
--when it is aborted. For instance, if cpu0 requests a restart then
--cpu1 will normally be the next cpu that is run. Cpu0 being restarted
--after all the other CPU's and the event queue have been processed */
--
-+ lf_putstr (file, "\
-+/* CASE 2: SMP (With or without ICACHE)\
-+\
-+The complexity here comes from needing to correctly halt the simulator\
-+when it is aborted. For instance, if cpu0 requests a restart then\
-+cpu1 will normally be the next cpu that is run. Cpu0 being restarted\
-+after all the other CPU's and the event queue have been processed */\
-+\
- ");
-
- lf_putstr (file, "\n");
diff --git a/devel/i386-rtems-gdb/files/patch-sim::igen::lf.c b/devel/i386-rtems-gdb/files/patch-sim::igen::lf.c
deleted file mode 100644
index 8b359d5c4e9a..000000000000
--- a/devel/i386-rtems-gdb/files/patch-sim::igen::lf.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- sim/igen/lf.c.orig Thu Apr 15 21:35:05 1999
-+++ sim/igen/lf.c Mon Feb 16 08:13:36 2004
-@@ -259,27 +259,27 @@
- case lf_is_c:
- case lf_is_h:
- nr += lf_printf(file, "\
--/* This file is part of the program psim.
--
-- Copyright (C) 1994-1997, Andrew Cagney <cagney@highland.com.au>
--
-- This program is free software; you can redistribute it and/or modify
-- it under the terms of the GNU General Public License as published by
-- the Free Software Foundation; either version 2 of the License, or
-- (at your option) any later version.
--
-- This program is distributed in the hope that it will be useful,
-- but WITHOUT ANY WARRANTY; without even the implied warranty of
-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
-- along with this program; if not, write to the Free Software
-- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
--
-- --
--
-- This file was generated by the program %s */
-+/* This file is part of the program psim.\
-+\
-+ Copyright (C) 1994-1997, Andrew Cagney <cagney@highland.com.au>\
-+\
-+ This program is free software; you can redistribute it and/or modify\
-+ it under the terms of the GNU General Public License as published by\
-+ the Free Software Foundation; either version 2 of the License, or\
-+ (at your option) any later version.\
-+\
-+ This program is distributed in the hope that it will be useful,\
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of\
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\
-+ GNU General Public License for more details.\
-+ \
-+ You should have received a copy of the GNU General Public License\
-+ along with this program; if not, write to the Free Software\
-+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.\
-+ \
-+ --\
-+\
-+ This file was generated by the program %s */\
- ", filter_filename(file->program));
- break;
- default:
diff --git a/devel/i386-rtems-gdb/files/patch-sim::ppc::gen-idecode.c b/devel/i386-rtems-gdb/files/patch-sim::ppc::gen-idecode.c
deleted file mode 100644
index fc0c12f18cca..000000000000
--- a/devel/i386-rtems-gdb/files/patch-sim::ppc::gen-idecode.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- sim/ppc/gen-idecode.c.orig Fri Feb 20 17:00:10 2004
-+++ sim/ppc/gen-idecode.c Fri Feb 20 17:00:57 2004
-@@ -757,21 +757,21 @@
-
- if (!generate_smp) {
-
-- lf_putstr(file, "
--/* CASE 1: NO SMP (with or with out instruction cache).
--
-- In this case, we can take advantage of the fact that the current
-- instruction address does not need to be returned to the cpu object
-- after every execution of an instruction. Instead it only needs to
-- be saved when either A. the main loop exits or B. A cpu-halt or
-- cpu-restart call forces the loop to be re-enered. The later
-- functions always save the current cpu instruction address.
--
-- Two subcases also exist that with and that without an instruction
-- cache.
--
-- An additional complexity is the need to ensure that a 1:1 ratio
-- is maintained between the execution of an instruction and the
-+ lf_putstr(file, "\
-+/* CASE 1: NO SMP (with or with out instruction cache).\
-+\
-+ In this case, we can take advantage of the fact that the current\
-+ instruction address does not need to be returned to the cpu object\
-+ after every execution of an instruction. Instead it only needs to\
-+ be saved when either A. the main loop exits or B. A cpu-halt or\
-+ cpu-restart call forces the loop to be re-enered. The later\
-+ functions always save the current cpu instruction address.\
-+\
-+ Two subcases also exist that with and that without an instruction\
-+ cache.\
-+\
-+ An additional complexity is the need to ensure that a 1:1 ratio\
-+ is maintained between the execution of an instruction and the\
- incrementing of the simulation clock */");
-
- lf_putstr(file, "\n");
-@@ -867,12 +867,12 @@
-
- if (generate_smp) {
-
-- lf_putstr(file, "
--/* CASE 2: SMP (With or without ICACHE)
--
-- The complexity here comes from needing to correctly restart the
-- system when it is aborted. In particular if cpu0 requests a
-- restart, the next cpu is still cpu1. Cpu0 being restarted after
-+ lf_putstr(file, "\
-+/* CASE 2: SMP (With or without ICACHE)\
-+\
-+ The complexity here comes from needing to correctly restart the\
-+ system when it is aborted. In particular if cpu0 requests a\
-+ restart, the next cpu is still cpu1. Cpu0 being restarted after\
- all the other CPU's and the event queue have been processed */");
-
- lf_putstr(file, "\n");
diff --git a/devel/i386-rtems-gdb/files/patch-sim::ppc::gen-model.c b/devel/i386-rtems-gdb/files/patch-sim::ppc::gen-model.c
deleted file mode 100644
index 7c1b25254a8c..000000000000
--- a/devel/i386-rtems-gdb/files/patch-sim::ppc::gen-model.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- sim/ppc/gen-model.c.orig Fri Feb 20 17:15:51 2004
-+++ sim/ppc/gen-model.c Fri Feb 20 17:18:16 2004
-@@ -377,7 +377,7 @@
- lf_printf(file, " }\n");
- lf_printf(file, " }\n");
- lf_printf(file, "\n");
-- lf_printf(file, " error(\"Unknown model '%%s', Models which are known are:%%s\n\",\n");
-+ lf_printf(file, " error(\"Unknown model '%%s', Models which are known are:%%s\",\n");
- lf_printf(file, " name,\n");
- lf_printf(file, " \"");
- for(model_ptr = models; model_ptr; model_ptr = model_ptr->next) {
diff --git a/devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c b/devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c
deleted file mode 100644
index 65ac6f8b2c76..000000000000
--- a/devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- sim/ppc/lf.c.orig Thu Apr 15 21:35:11 1999
-+++ sim/ppc/lf.c Mon Feb 16 08:09:23 2004
-@@ -274,27 +274,27 @@
- case lf_is_c:
- case lf_is_h:
- nr += lf_printf(file, "\
--/* This file is part of the program psim.
--
-- Copyright (C) 1994-1995, Andrew Cagney <cagney@highland.com.au>
--
-- This program is free software; you can redistribute it and/or modify
-- it under the terms of the GNU General Public License as published by
-- the Free Software Foundation; either version 2 of the License, or
-- (at your option) any later version.
--
-- This program is distributed in the hope that it will be useful,
-- but WITHOUT ANY WARRANTY; without even the implied warranty of
-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
-- along with this program; if not, write to the Free Software
-- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
--
-- --
--
-- This file was generated by the program %s */
-+/* This file is part of the program psim.\
-+\
-+ Copyright (C) 1994-1995, Andrew Cagney <cagney@highland.com.au>\
-+\
-+ This program is free software; you can redistribute it and/or modify\
-+ it under the terms of the GNU General Public License as published by\
-+ the Free Software Foundation; either version 2 of the License, or\
-+ (at your option) any later version.\
-+\
-+ This program is distributed in the hope that it will be useful,\
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of\
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\
-+ GNU General Public License for more details.\
-+ \
-+ You should have received a copy of the GNU General Public License\
-+ along with this program; if not, write to the Free Software\
-+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.\
-+ \
-+ --\
-+\
-+ This file was generated by the program %s */\
- ", filter_filename(file->program));
- break;
- default:
diff --git a/devel/i386-rtems-gdb/pkg-descr b/devel/i386-rtems-gdb/pkg-descr
deleted file mode 100644
index d7a5fd0f1ed2..000000000000
--- a/devel/i386-rtems-gdb/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-The base port for all the RTEMS gdb ports. RTEMS is a
-Real-Time Operating System of Embedded Software development.
-It has its origins in the US Military, but is now open-source
-and supported by a wide varity of GNU tool languages. It
-a large number of processors and systems.
-
-WWW: http://www.rtems.com/
-
-- Jim
-jim@thehousleys.net
diff --git a/devel/i386-rtems-gdb/pkg-plist b/devel/i386-rtems-gdb/pkg-plist
deleted file mode 100644
index 549a621fec0c..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment this plist intentionally left empty
diff --git a/devel/i386-rtems-gdb/pkg-plist.arm-rtems b/devel/i386-rtems-gdb/pkg-plist.arm-rtems
deleted file mode 100644
index b7f122541669..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.arm-rtems
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/arm-rtems-gdb
-bin/arm-rtems-run
-lib/libarm-rtems-sim.a
diff --git a/devel/i386-rtems-gdb/pkg-plist.i386-rtems b/devel/i386-rtems-gdb/pkg-plist.i386-rtems
deleted file mode 100644
index 1e4d25ce1729..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.i386-rtems
+++ /dev/null
@@ -1 +0,0 @@
-bin/i386-rtems-gdb
diff --git a/devel/i386-rtems-gdb/pkg-plist.i960-rtems b/devel/i386-rtems-gdb/pkg-plist.i960-rtems
deleted file mode 100644
index 97cd9078a8c7..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.i960-rtems
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/i960-rtems-gdb
-bin/i960-rtems-run
-lib/libi960-rtems-sim.a
diff --git a/devel/i386-rtems-gdb/pkg-plist.m68k-rtems b/devel/i386-rtems-gdb/pkg-plist.m68k-rtems
deleted file mode 100644
index 66ca3e8262b0..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.m68k-rtems
+++ /dev/null
@@ -1 +0,0 @@
-bin/m68k-rtems-gdb
diff --git a/devel/i386-rtems-gdb/pkg-plist.mips-rtems b/devel/i386-rtems-gdb/pkg-plist.mips-rtems
deleted file mode 100644
index 71cb2bcfe917..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.mips-rtems
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/mips-rtems-gdb
-bin/mips-rtems-run
-lib/libmips-rtems-sim.a
diff --git a/devel/i386-rtems-gdb/pkg-plist.powerpc-rtems b/devel/i386-rtems-gdb/pkg-plist.powerpc-rtems
deleted file mode 100644
index 2c804e502677..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.powerpc-rtems
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/powerpc-rtems-gdb
-bin/powerpc-rtems-run
diff --git a/devel/i386-rtems-gdb/pkg-plist.sh-rtems b/devel/i386-rtems-gdb/pkg-plist.sh-rtems
deleted file mode 100644
index 41f7d7067e54..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.sh-rtems
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/sh-rtems-gdb
-bin/sh-rtems-run
-lib/libsh-rtems-sim.a
diff --git a/devel/i386-rtems-gdb/pkg-plist.sparc-rtems b/devel/i386-rtems-gdb/pkg-plist.sparc-rtems
deleted file mode 100644
index 49c66bc7e7f2..000000000000
--- a/devel/i386-rtems-gdb/pkg-plist.sparc-rtems
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/sparc-rtems-gdb
-%%SPARC_NOSIM%%bin/sparc-rtems-run
-%%SPARC_NOSIM%%bin/sparc-rtems-sis
-%%SPARC_NOSIM%%lib/libsparc-rtems-sim.a