aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-objc
diff options
context:
space:
mode:
Diffstat (limited to 'devel/i386-rtems-objc')
-rw-r--r--devel/i386-rtems-objc/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index 2806a503b970..30e7184f1d6a 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -56,14 +56,9 @@ CONFIGURE_SCRIPT?= ../${OBJCNAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-NO_CPU_FLAGS= true
+WITHOUT_CPU_CFLAGS= yes
MAKE_FLAGS= LANGUAGES="objc"
MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
-# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
-# by NO_CPU_FLAGS, and since they are added long before here we are
-# stuck with this hack.
-CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
-CXXFLAGS:= ${CXXFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
pre-configure:
@(cd ${WRKDIR} ; \