aboutsummaryrefslogtreecommitdiff
path: root/devel/imake
diff options
context:
space:
mode:
Diffstat (limited to 'devel/imake')
-rw-r--r--devel/imake/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index fa9ac23f4f43..d4d95da49a57 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -39,4 +39,16 @@ MAN1= ccmakedep.1 \
post-patch:
@${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/mkhtmlindex.pl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
+# which is fatal for imake.
+.if defined(CC) && ${CC} == "clang"
+RUN_DEPENDS+= ucpp:{PORTSDIR}/devel/ucpp
+CONFIGURE_ENV+= ac_cv_path_RAWCPP="ucpp -s"
+
+post-build:
+ ${REINPLACE_CMD} -e 's|^configdirspec= *|configdirspec=|' ${WRKSRC}/xmkmf
+.endif
+
+.include <bsd.port.post.mk>