aboutsummaryrefslogtreecommitdiff
path: root/devel/ipython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ipython/Makefile')
-rw-r--r--devel/ipython/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index 8f38d540402b..cfc975ef78d8 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ipython
PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,11 +17,15 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=2:${PORTSDIR}/misc/py-pexpect \
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-PYTHON_PY3K_PLIST_HACK=yes
+PYDISTUTILS_AUTOPLIST=yes
OPTIONS_DEFINE= X11 HTML_NOTEBOOK ZMQ
OPTIONS_DEFAULT=X11 ZMQ
+.if defined(PACKAGE_BUILDING)
+OPTIONS_DEFAULT+= HTML_NOTEBOOK
+.endif
+
HTML_NOTEBOOK_DESC= HTML notebook support
ZMQ_DESC= ZMQ support (parallel computing, qt console, notebook)
@@ -47,12 +51,4 @@ post-install:
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_MAJOR_VER} == "3"
-PLIST_SUB+= IPYTHON_SUFFIX="3"
-.else
-PLIST_SUB+= IPYTHON_SUFFIX=""
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>