aboutsummaryrefslogtreecommitdiff
path: root/devel/jep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/jep/Makefile')
-rw-r--r--devel/jep/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/jep/Makefile b/devel/jep/Makefile
new file mode 100644
index 000000000000..3a0a6ab60f03
--- /dev/null
+++ b/devel/jep/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jep
+# Date created: 2005-03-04
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= jep
+PORTVERSION= 1.1
+CATEGORIES= devel java python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= Java Embedded Python
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= JAVA_HOME=${JAVA_HOME}
+CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX}
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+USE_PYTHON= yes
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+MAN1= jep.1
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/jep.jar ${JAVAJARDIR}
+
+.include <bsd.port.mk>