aboutsummaryrefslogtreecommitdiff
path: root/devel/jwasm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/jwasm/Makefile')
-rw-r--r--devel/jwasm/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/jwasm/Makefile b/devel/jwasm/Makefile
new file mode 100644
index 000000000000..da92fe3a96b9
--- /dev/null
+++ b/devel/jwasm/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jwasm
+# Date created: 7 April 2009
+# Whom: Pedro F. Giffuni <giffunip@tutopia.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jwasm
+PORTVERSION= 204
+CATEGORIES= devel
+MASTER_SITES= http://www.japheth.de/Download/JWasm/
+DISTNAME= JWasm${PORTVERSION}cs
+
+MAINTAINER= giffunip@tutopia.com
+COMMENT= Fork of OpenWatcom's x86 assembler with AMD64 support
+
+ONLY_FOR_ARCHS= amd64 i386
+
+USE_ZIP= yes
+USE_GMAKE= yes
+MAKEFILE= GccUnix.mak
+NO_WRKSUBDIR= yes
+EXTRACT_BEFORE_ARGS= -qa
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/GccUnixR/jwasm ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+ @${GZIP_CMD} ${DOCSDIR}/*.txt
+.endif
+
+.include <bsd.port.mk>