aboutsummaryrefslogtreecommitdiff
path: root/devel/kcachegrind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kcachegrind/Makefile')
-rw-r--r--devel/kcachegrind/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/kcachegrind/Makefile b/devel/kcachegrind/Makefile
new file mode 100644
index 000000000000..ebc195c4f029
--- /dev/null
+++ b/devel/kcachegrind/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: KCachegrind
+# Date created: Jun 3 2004
+# Whom: Simon Barner <barner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kcachegrind
+PORTVERSION= 0.4.5
+CATEGORIES= devel kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kcachegrind
+
+MAINTAINER= barner@gmx.de
+COMMENT= Profiling Visualization Tool
+
+BUILD_DEPENDS= mcopidl:${PORTSDIR}/audio/arts
+RUN_DEPENDS= calltree:${PORTSDIR}/devel/calltree
+
+CONFLICTS= kdesdk3-[0-9]*
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>