aboutsummaryrefslogtreecommitdiff
path: root/devel/kdebindings4-python-pykde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kdebindings4-python-pykde4/Makefile')
-rw-r--r--devel/kdebindings4-python-pykde4/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/kdebindings4-python-pykde4/Makefile b/devel/kdebindings4-python-pykde4/Makefile
index e2ce54482d64..4597cf91e42f 100644
--- a/devel/kdebindings4-python-pykde4/Makefile
+++ b/devel/kdebindings4-python-pykde4/Makefile
@@ -31,6 +31,12 @@ SUB_LIST= PYTHONPREFIX_SITELIBDIR=${PYTHONPREFIX_SITELIBDIR}
EXAMPLESDIR= ${PREFIX}/share/examples/pykde4
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+BROKEN= Fails to build with RTLD_NOLOAD
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's,$${SIP_DEFAULT_SIP_DIR},${PREFIX}/${SIPDIR_REL},g' \
-e 's,$${PYTHON_SITE_PACKAGES_DIR},${PYTHONPREFIX_SITELIBDIR},g' \
@@ -51,4 +57,5 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/kdebindings4.pth ${PYTHON_SITELIBDIR}
.include "${.CURDIR}/../../devel/kdebindings4/files/Makefile.kdebindings"
-.include <bsd.port.mk>
+
+.include <bsd.port.post.mk>