aboutsummaryrefslogtreecommitdiff
path: root/devel/kdesdk3
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kdesdk3')
-rw-r--r--devel/kdesdk3/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/devel/kdesdk3/Makefile b/devel/kdesdk3/Makefile
index f357315d52f7..7f6254991aff 100644
--- a/devel/kdesdk3/Makefile
+++ b/devel/kdesdk3/Makefile
@@ -15,7 +15,6 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Software Development Kit
-RUN_DEPENDS= calltree:${PORTSDIR}/devel/calltree
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
CONFLICTS= umbrello-[0-9]* kcachegrind-[0-9]*
@@ -32,10 +31,18 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+# calltree is a plugin for valgrind, which is i386-only
+# kcachegrind however likes to use them both, so we depend
+# on them in the i386-case
+.if ${ARCH} == "i386"
+RUN_DEPENDS+= calltree:${PORTSDIR}/devel/calltree
+.endif
+
pre-configure:
@${REINPLACE_CMD} -e 's|-I$$ac_db_includes|-I${LOCALBASE}/include/db4|g' \
-e 's|ac_db_name="db"|ac_db_name="db4"|g' ${WRKSRC}/configure
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>