aboutsummaryrefslogtreecommitdiff
path: root/devel/kdevelop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kdevelop/Makefile')
-rw-r--r--devel/kdevelop/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 2c06c48f8cba..c6c695a18aca 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libkasten3controllers.so:devel/okteta \
RUN_DEPENDS= gmake:devel/gmake
USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
- gettext grantlee:5 kde:5 shared-mime-info shebangfix tar:xz
+ gettext grantlee:5 kde:5 qt:5 shared-mime-info shebangfix tar:xz
USE_KDE= archive attica auth bookmarks codecs completion config configwidgets \
coreaddons crash guiaddons emoticons i18n iconthemes init \
itemmodels itemviews jobwidgets kcmutils kdeclarative \
@@ -30,7 +30,7 @@ USE_KDE= archive attica auth bookmarks codecs completion config configwidgets \
notifyconfig package parts plasma-framework \
runner service solid sonnet texteditor textwidgets threadweaver \
widgetsaddons windowsystem xmlgui
-USE_QT5= concurrent core dbus gui help network qml quick \
+USE_QT= concurrent core dbus gui help network qml quick \
script sql widgets xml buildtools_build qmake_build
CONFLICTS= kdevelop-kde4-4* kdevelop-4* kdevplatform-kde4-4* kdevplatform-4*
SHEBANG_FILES= kdevplatform/util/kdevplatform_shell_environment.sh \
@@ -38,8 +38,9 @@ SHEBANG_FILES= kdevplatform/util/kdevplatform_shell_environment.sh \
OPTIONS_DEFINE= WEBENGINE
WEBENGINE_DESC= Use WebEngine as help reader
-WEBENGINE_USE= QT5=location,webchannel,webengine
-WEBENGINE_USE_OFF= QT5=webkit
+WEBENGINE_USES= qt:5
+WEBENGINE_USE= QT=location,webchannel,webengine
+WEBENGINE_USE_OFF= QT=webkit
WEBENGINE_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets:BOOL=TRUE
SHEBANG_LANG= zsh