aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-knewstuff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kf5-knewstuff/Makefile')
-rw-r--r--devel/kf5-knewstuff/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devel/kf5-knewstuff/Makefile b/devel/kf5-knewstuff/Makefile
new file mode 100644
index 000000000000..a6915ab44cd1
--- /dev/null
+++ b/devel/kf5-knewstuff/Makefile
@@ -0,0 +1,19 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= knewstuff
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= devel kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 library for downloading application assets from the network
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= archive attica5 auth codecs completion config \
+ configwidgets coreaddons ecm i18n iconthemes itemviews \
+ jobwidgets kio service sonnet textwidgets widgetsaddons \
+ xmlgui
+USE_QT5= buildtools_build core dbus gui network qmake_build \
+ widgets xml
+
+.include <bsd.port.mk>